4.1.4: Media Notification does not Follow Dark Theme #454

Closed
opened 3 months ago by leopold · 5 comments

Describe the bug
Media notification does not follow the system dark theme

To Reproduce
Steps to reproduce the behavior:

  1. Set system theme to light
  2. Launch Transistor and start any stream
  3. Note the media notification reflects a white background with legible black text
  4. Close media notification and end the Transistor process
  5. Set system theme to dark
  6. Launch Transistor and start any stream
  7. Note the white background instead of white text on black background

Expected behavior
Media Notification follows system dark theme i.e. dark background with light text

Screenshots
See attached.

Device:

  • Device: Pixel 6
  • OS: GrapheneOS TQ1A.230205.002.2023022300 (stable)
  • Version: 4.1.4 (release)

Additional context
Also tested on Pixel P5a with same bug present.

**Describe the bug** Media notification does not follow the system dark theme **To Reproduce** Steps to reproduce the behavior: 1. Set system theme to light 2. Launch Transistor and start any stream 3. Note the media notification reflects a white background with legible black text 4. Close media notification and end the Transistor process 5. Set system theme to dark 6. Launch Transistor and start any stream 7. Note the white background instead of white text on black background **Expected behavior** Media Notification follows system dark theme i.e. dark background with light text **Screenshots** See attached. **Device:** - Device: Pixel 6 - OS: GrapheneOS TQ1A.230205.002.2023022300 (stable) - Version: 4.1.4 (release) **Additional context** Also tested on Pixel P5a with same bug present.
leopold added the
bug
label 3 months ago
y20k commented 3 months ago
Owner

Hi @leopold

thank you. That is an interesting bug. For me the notification font color / the whole notification does not change. I am not sure how to reproduce the problem. How did you set the white background on your example screen.

Hi @leopold thank you. That is an interesting bug. For me the notification font color / the whole notification does not change. I am not sure how to reproduce the problem. How did you set the white background on your example screen.
Poster

Transistor process must be closed in between theme changes, else the media notification follows the previously set theme. For the first screen, the system theme was set to light. Second screen, system theme was set to dark and Transistor closed/restarted to adopt the updated dark theme. No issues with 4.1.3, perhaps the monochrome icon logic somehow affected the notification?

Transistor process must be closed in between theme changes, else the media notification follows the previously set theme. For the first screen, the system theme was set to light. Second screen, system theme was set to dark and Transistor closed/restarted to adopt the updated dark theme. No issues with 4.1.3, perhaps the monochrome icon logic somehow affected the notification?
y20k commented 3 months ago
Owner

I think I probably found the issue. In your screenshots the notification background is white because the default station icon is not shown. I will fix that and lets see if that fixes your problem, too.

(I do not set any colors / font colors in the notification - only the station image and the station name.)

I think I probably found the issue. In your screenshots the notification background is white because the default station icon is not shown. I will fix that and lets see if that fixes your problem, too. (I do not set any colors / font colors in the notification - only the station image and the station name.)
y20k commented 3 months ago
Owner

Hi @leopold

I think this problem is fixed with v4.1.5, which should appear on F-Droid in the next couple of days.

Hi @leopold I think this problem is fixed with [v4.1.5](https://codeberg.org/y20k/transistor/releases/tag/v4.1.5), which should appear on F-Droid in the next couple of days.
Poster

Resolved with 4.1.5 across all of our devices which were previously affected. Thanks!

Resolved with 4.1.5 across all of our devices which were previously affected. Thanks!
y20k closed this issue 3 months ago
Sign in to join this conversation.
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: y20k/transistor#454
Loading…
There is no content yet.