Connected but not synchronized #2

Closed
opened 1 year ago by tecwando · 5 comments
tecwando commented 1 year ago

Hi

As in topic all my devices are shown as connected - not synchronized. Any change i make in the parent device is not being synchronized to the child devices and vice versa. I am using my own server on docker. The whole setup worked a few month till last week.
Were can i start investigate the issue?

Regards

Hi As in topic all my devices are shown as connected - not synchronized. Any change i make in the parent device is not being synchronized to the child devices and vice versa. I am using my own server on docker. The whole setup worked a few month till last week. Were can i start investigate the issue? Regards
Owner

You can shutdown the container (docker-compose down), enable the logging if it is disabled and run it with docker-compose up (without -d) to get the output on the screen (note that this will shutdown the server again when pressing Crtl + C). Additionally, there is the admin UI which shows counters for some errors.

It could be that you are using a client with https://codeberg.org/timelimit/timelimit-android/commit/5a21314495380a907a29d705579a0552ca2322be but a server version without https://codeberg.org/timelimit/timelimit-server/commit/ef1b19a01c36c494acf8a0dce1ac19521adb53b1 - this could cause such problems.

In most cases, using a old server version just causes the new client features to not work - but in some cases this is not easily possible, so it causes such effects.

Another possible cause is that the database content was somehow deleted. The client does retry when the server does not detect it. (differnt if its id was saved in the list of removed devices, then the client is told to reset itself)

The client UI is currently not very helpful in such cases.

You can shutdown the container (``docker-compose down``), enable the logging if it is disabled and run it with ``docker-compose up`` (without ``-d``) to get the output on the screen (note that this will shutdown the server again when pressing Crtl + C). Additionally, there is the admin UI which shows counters for some errors. It could be that you are using a client with <https://codeberg.org/timelimit/timelimit-android/commit/5a21314495380a907a29d705579a0552ca2322be> but a server version without <https://codeberg.org/timelimit/timelimit-server/commit/ef1b19a01c36c494acf8a0dce1ac19521adb53b1> - this could cause such problems. In most cases, using a old server version just causes the new client features to not work - but in some cases this is not easily possible, so it causes such effects. Another possible cause is that the database content was somehow deleted. The client does retry when the server does not detect it. (differnt if its id was saved in the list of removed devices, then the client is told to reset itself) The client UI is currently not very helpful in such cases.
Poster

I have done an update via git pull https://codeberg.org/timelimit/timelimit-server.git
an then started the server
this is the output

database_1  | 2020-06-30 05:40:55+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.4.12+maria~bionic started.
database_1  | 2020-06-30 05:40:57+00:00 [Note] [Entrypoint]: Switching to dedicated user 'mysql'
database_1  | 2020-06-30 05:40:57+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.4.12+maria~bionic started.
database_1  | 2020-06-30  5:40:57 0 [Note] mysqld (mysqld 10.4.12-MariaDB-1:10.4.12+maria~bionic) starting as process 1 ...
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Using Linux native AIO
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Uses event mutexes
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Number of pools: 1
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Using SSE2 crc32 instructions
database_1  | 2020-06-30  5:40:58 0 [Note] mysqld: O_TMPFILE is not supported on /tmp (disabling future attempts)
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Initializing buffer pool, total size = 256M, instances = 1, chunk size = 128M
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Completed initialization of buffer pool
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: 128 out of 128 rollback segments are active.
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Creating shared tablespace for temporary tables
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Waiting for purge to start
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: 10.4.12 started; log sequence number 44894467; transaction id 19998
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
database_1  | 2020-06-30  5:40:58 0 [Note] Plugin 'FEEDBACK' is disabled.
database_1  | 2020-06-30  5:40:58 0 [Note] Server socket created on IP: '::'.
database_1  | 2020-06-30  5:40:58 0 [Warning] 'proxies_priv' entry '@% root@8bb6412b8787' ignored in --skip-name-resolve mode.
database_1  | 2020-06-30  5:40:58 0 [Note] InnoDB: Buffer pool(s) load completed at 200630  5:40:58
database_1  | 2020-06-30  5:40:58 0 [Note] Reading of all Master_info entries succeeded
database_1  | 2020-06-30  5:40:58 0 [Note] Added new Master_info '' to hash table
database_1  | 2020-06-30  5:40:58 0 [Note] mysqld: ready for connections.
database_1  | Version: '10.4.12-MariaDB-1:10.4.12+maria~bionic'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  mariadb.org binary distribution
api_1       | 
api_1       | > timelimit-server-2018@0.0.0 start /usr/src/app
api_1       | > node ./build/index.js
api_1       | 
api_1       | warning: please use IANA standard timezone format ('Etc/GMT0')
api_1       | warning: please use IANA standard timezone format ('Etc/GMT0')
api_1       | ready
api_1       | warning: please use IANA standard timezone format ('Etc/GMT0')
api_1       | BadRequestError: Bad Request
api_1       |     at router.post (/usr/src/app/build/api/sync.js:65:23)
api_1       |     at Layer.handle [as handle_request] (/usr/src/app/node_modules/express/lib/router/layer.js:95:5)
api_1       |     at next (/usr/src/app/node_modules/express/lib/router/route.js:137:13)
api_1       |     at /usr/src/app/node_modules/body-parser/lib/read.js:130:5
api_1       |     at invokeCallback (/usr/src/app/node_modules/raw-body/index.js:224:16)
api_1       |     at done (/usr/src/app/node_modules/raw-body/index.js:213:7)
api_1       |     at Gunzip.onEnd (/usr/src/app/node_modules/raw-body/index.js:273:7)
api_1       |     at Gunzip.emit (events.js:198:15)
api_1       |     at endReadableNT (_stream_readable.js:1139:12)
api_1       |     at processTicksAndRejections (internal/process/task_queues.js:81:17)
api_1       | BadRequestError: Bad Request

I have done an update via git pull https://codeberg.org/timelimit/timelimit-server.git an then started the server this is the output ``` database_1 | 2020-06-30 05:40:55+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.4.12+maria~bionic started. database_1 | 2020-06-30 05:40:57+00:00 [Note] [Entrypoint]: Switching to dedicated user 'mysql' database_1 | 2020-06-30 05:40:57+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.4.12+maria~bionic started. database_1 | 2020-06-30 5:40:57 0 [Note] mysqld (mysqld 10.4.12-MariaDB-1:10.4.12+maria~bionic) starting as process 1 ... database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Using Linux native AIO database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Uses event mutexes database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Compressed tables use zlib 1.2.11 database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Number of pools: 1 database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Using SSE2 crc32 instructions database_1 | 2020-06-30 5:40:58 0 [Note] mysqld: O_TMPFILE is not supported on /tmp (disabling future attempts) database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Initializing buffer pool, total size = 256M, instances = 1, chunk size = 128M database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Completed initialization of buffer pool database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority(). database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: 128 out of 128 rollback segments are active. database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Creating shared tablespace for temporary tables database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ... database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB. database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Waiting for purge to start database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: 10.4.12 started; log sequence number 44894467; transaction id 19998 database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool database_1 | 2020-06-30 5:40:58 0 [Note] Plugin 'FEEDBACK' is disabled. database_1 | 2020-06-30 5:40:58 0 [Note] Server socket created on IP: '::'. database_1 | 2020-06-30 5:40:58 0 [Warning] 'proxies_priv' entry '@% root@8bb6412b8787' ignored in --skip-name-resolve mode. database_1 | 2020-06-30 5:40:58 0 [Note] InnoDB: Buffer pool(s) load completed at 200630 5:40:58 database_1 | 2020-06-30 5:40:58 0 [Note] Reading of all Master_info entries succeeded database_1 | 2020-06-30 5:40:58 0 [Note] Added new Master_info '' to hash table database_1 | 2020-06-30 5:40:58 0 [Note] mysqld: ready for connections. database_1 | Version: '10.4.12-MariaDB-1:10.4.12+maria~bionic' socket: '/var/run/mysqld/mysqld.sock' port: 3306 mariadb.org binary distribution api_1 | api_1 | > timelimit-server-2018@0.0.0 start /usr/src/app api_1 | > node ./build/index.js api_1 | api_1 | warning: please use IANA standard timezone format ('Etc/GMT0') api_1 | warning: please use IANA standard timezone format ('Etc/GMT0') api_1 | ready api_1 | warning: please use IANA standard timezone format ('Etc/GMT0') api_1 | BadRequestError: Bad Request api_1 | at router.post (/usr/src/app/build/api/sync.js:65:23) api_1 | at Layer.handle [as handle_request] (/usr/src/app/node_modules/express/lib/router/layer.js:95:5) api_1 | at next (/usr/src/app/node_modules/express/lib/router/route.js:137:13) api_1 | at /usr/src/app/node_modules/body-parser/lib/read.js:130:5 api_1 | at invokeCallback (/usr/src/app/node_modules/raw-body/index.js:224:16) api_1 | at done (/usr/src/app/node_modules/raw-body/index.js:213:7) api_1 | at Gunzip.onEnd (/usr/src/app/node_modules/raw-body/index.js:273:7) api_1 | at Gunzip.emit (events.js:198:15) api_1 | at endReadableNT (_stream_readable.js:1139:12) api_1 | at processTicksAndRejections (internal/process/task_queues.js:81:17) api_1 | BadRequestError: Bad Request ```
Owner

pullStatusRequest invalid is written in the line above /usr/src/app/build/api/sync.js:65:23 and that's it.

Please run sudo docker build -t timelimit-server first and do another docker-compose up -d after it - otherwise the old version (for which you've build the docker image during the initial installation) will be used.

``pullStatusRequest invalid`` is written in the line above ``/usr/src/app/build/api/sync.js:65:23`` and that's it. Please run ``sudo docker build -t timelimit-server`` first and do another ``docker-compose up -d`` after it - otherwise the old version (for which you've build the docker image during the initial installation) will be used.
Owner

I assume that the old server version was the cause - if that wasn't it, then please reopen this

I assume that the old server version was the cause - if that wasn't it, then please reopen this
jonas-l closed this issue 1 year ago
Poster

yes the old server was the cause. now it works.

yes the old server was the cause. now it works.
Sign in to join this conversation.
No Label
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.