/u/ page drops sort parameter from "next" and "prev" links #194

Closed
opened 2 years ago by jbosboom · 0 comments

Steps to reproduce:

  1. Navigate to https://teddit.net/u/MTGCardFetcher .
  2. Expand "Sorted by new", then click any of the "hot", "top" or "controversial" links.
  3. Scroll to the bottom of the page. Observe that the "next ›" link does not have a sort parameter, so clicking that link always goes to the second page of the "new" sort.
  4. Manually edit the URL to add the missing parameter and visit that URL.
  5. Scroll to the bottom of the page. Observe that both the "‹ prev" and "next ›" links lack the sort parameter.

While writing up this issue, I also noticed that "top" and "controversial" links have the t parameter present, but empty. That doesn't seem to break anything (it correctly defaults to "all time"), but may not be intended.

Steps to reproduce: 1. Navigate to https://teddit.net/u/MTGCardFetcher . 2. Expand "Sorted by new", then click any of the "hot", "top" or "controversial" links. 3. Scroll to the bottom of the page. Observe that the "next ›" link does not have a `sort` parameter, so clicking that link always goes to the second page of the "new" sort. 4. Manually edit the URL to add the missing parameter and visit that URL. 5. Scroll to the bottom of the page. Observe that both the "‹ prev" and "next ›" links lack the `sort` parameter. While writing up this issue, I also noticed that "top" and "controversial" links have the `t` parameter present, but empty. That doesn't seem to break anything (it correctly defaults to "all time"), but may not be intended.
teddit added the
bug
label 2 years ago
teddit closed this issue 2 years ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: teddit/teddit#194
Loading…
There is no content yet.