Winter Break #39

Closed
opened 10 months ago by baobab · 13 comments
baobab commented 10 months ago
Owner

Since next week starts winter break, I'll be testing some browsers and writing && rewriting some articles.

  • SeaMonkey (Long overdue)
  • Brave (I've heard they changed some things such as the auto updates), Done
  • Chromium (Long overdue), Maybe another day
  • Luakit (@acz told me about this one), Maybe another day
  • Waterfox (@spywarebuster's idea), Done

Maybe if I have time:

  • Vivaldi
  • Dissenter

Any other software that needs testing || retesting?

Since next week starts winter break, I'll be testing some browsers and writing && rewriting some articles. - SeaMonkey (Long overdue) - Brave (I've heard they changed some things such as the auto updates), Done - Chromium (Long overdue), Maybe another day - Luakit (@acz told me about this one), Maybe another day - Waterfox (@spywarebuster's idea), Done Maybe if I have time: - Vivaldi - Dissenter Any other software that needs testing || retesting?
baobab added the
enhancement
label 10 months ago

Waterfox, probably. Vivaldi. Maybe Dissenter.

Waterfox, probably. Vivaldi. Maybe Dissenter.
Poster
Owner

Yeah I forgot about Waterfox. I'll relook at Vivaldi && Dissenter if I still have time.

Yeah I forgot about Waterfox. I'll relook at Vivaldi && Dissenter if I still have time.

I think i can take care of this

I think i can take care of this

Got this in seamonkey, in other words, i can't

Got this in seamonkey, in other words, i can't
Poster
Owner

Does mitmproxy require OpenSSL?
I was able to use mitmproxy on Gentoo with LibreSSL. Have you tried a distro other than Void @qorg11?

Does mitmproxy require OpenSSL? I was able to use mitmproxy on Gentoo with LibreSSL. Have you tried a distro other than Void @qorg11?

Yeah might want to check out Brave™ again, they've basically added their own version of mozilla's pocket to their browser for some reason.

https://brave.com/brave-today/

Yeah might want to check out Brave™ again, they've basically added their own version of mozilla's pocket to their browser for some reason. https://brave.com/brave-today/
Poster
Owner

It doesn't look very good for SeaMonkey. It looks like that browser uses location services, Google SafeBrowsing, automatic updates, and more.

It doesn't look very good for SeaMonkey. It looks like that browser uses location services, Google SafeBrowsing, automatic updates, and more.
Owner

Doesn't look good for Waterfox-current either.
Make a whole bunch of automatic connections still.

But at least their website uses Matomo instead of Google Analytics!! lol

Doesn't look good for Waterfox-current either. Make a whole bunch of automatic connections still. But at least their website uses Matomo instead of Google Analytics!! lol
baobab referenced this issue from a commit 10 months ago
Poster
Owner

The article on Brave is finished, I plan on testing SeaMonkey now.
@anonymous, can you take care of Luakit?

The article on Brave is finished, I plan on testing SeaMonkey now. @anonymous, can you take care of Luakit?
baobab added the
help wanted
label 10 months ago

Any chances of rating Librewolf?

Any chances of rating Librewolf?
Poster
Owner

I think @anonymous is currently testing it. Unless if I'm mistaken, there was a strange connection librewolf made. So we let the developers know about it to see if it will get fixed before writing the article.

I think @anonymous is currently testing it. Unless if I'm mistaken, there was a strange connection librewolf made. So we let the developers know about it to see if it will get fixed before writing the article.
Owner

@anonymous, can you take care of Luakit?

Didn't @qorg11 already do it?

Any chances of rating Librewolf?

Yeah this is still in process.
Here's the issue:
https://gitlab.com/librewolf-community/browser/common/-/issues/10 (warning: JabbaScript)

In other news I just went through SeaMonkey.
There's no apparent way to disable it's automatic connections. Some of it can be turned off, but it's doesn't fully mitigate it, just takes it from "High" to "Medium".

> @anonymous, can you take care of Luakit? Didn't @qorg11 already do it? > Any chances of rating Librewolf? Yeah this is still in process. Here's the issue: https://gitlab.com/librewolf-community/browser/common/-/issues/10 (warning: JabbaScript) In other news I just went through SeaMonkey. There's no apparent way to disable it's automatic connections. Some of it can be turned off, but it's doesn't fully mitigate it, just takes it from "High" to "Medium".
Poster
Owner

During spring break, I'll go into depth what the Chromium connections actually do. I'll close this issue now since winter break is finished.

During spring break, I'll go into depth what the Chromium connections actually do. I'll close this issue now since winter break is finished.
baobab closed this issue 9 months ago
Sign in to join this conversation.
No Milestone
No Assignees
6 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.