Question: JsLibCache? #965

Closed
opened 4 weeks ago by colbergv · 3 comments
colbergv commented 4 weeks ago

Hi, this is a question, not a bug report.
I'm wondering if adding the JsLibCache extension
https://addons.mozilla.org/en-US/firefox/addon/jslibcache/
will make any difference when I'm already running LocalCDN?
I'm using FF by the way.
Thank you.

Hi, this is a question, not a bug report. I'm wondering if adding the JsLibCache extension https://addons.mozilla.org/en-US/firefox/addon/jslibcache/ will make any difference when I'm already running LocalCDN? I'm using FF by the way. Thank you.
nobody added the
question/discussion
label 4 weeks ago
Owner

I have not tried that. Both extensions use the onBeforeRequest function. It is possible that either only one extension processes the requests at a time (first come first served) or alternately.

I have not tried that. Both extensions use the [onBeforeRequest](https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/webRequest/onBeforeRequest) function. It is possible that either only one extension processes the requests at a time (first come first served) or alternately.
Poster

From my personal usage, it seems that JsLibCache serves first, if the resources are not cached by JsLibCache, then LocalCDN will serve. Although I am aware that the raw number of resrouces LocalCDN has is higher than JsLibCache, I'm curious if there is any advantage to have JsLibCache besides LocalCDN or if it just adds extra weight.

From my personal usage, it seems that JsLibCache serves first, if the resources are not cached by JsLibCache, then LocalCDN will serve. Although I am aware that the raw number of resrouces LocalCDN has is higher than JsLibCache, I'm curious if there is any advantage to have JsLibCache besides LocalCDN or if it just adds extra weight.
Owner

I don't know Firefox's internal stuff in detail, but it's possible that JsLibCache serves first because it was installed first. Anyway, theoretically JsLibCache should be able to intercept any request. Only if that is not possible because it is a font or an unsupported CDN then LocalCDN would see the request.

I've never tried this and don't see any advantage in it, but it's highly dependent on the websites you visit.

I don't know Firefox's internal stuff in detail, but it's possible that JsLibCache serves first because it was installed first. Anyway, theoretically JsLibCache should be able to intercept any request. Only if that is not possible because it is a font or an unsupported CDN then LocalCDN would see the request. I've never tried this and don't see any advantage in it, but it's highly dependent on the websites you visit.
nobody closed this issue 3 weeks ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.