deepl.com loses its favicon and page name when using HTML filter #782

Closed
opened 2 weeks ago by Ficetto · 1 comments
Ficetto commented 2 weeks ago

Going to deepl.com while the HTML filter is turned on will cause the site to lose its favicon and name.

With HTML filter:
image

Without HTML filter:
image

The obvious workaround is to turn it off for this site, but I've had it active for a while, and it only recently started happening. So I'm assuming it might be a bug.

Going to deepl.com while the HTML filter is turned on will cause the site to lose its favicon and name. With HTML filter: ![image](/attachments/b14afdfb-f243-4a26-86e2-f4aef213482c) Without HTML filter: ![image](/attachments/3fd171d9-fd43-4115-a149-0d9a56ae29ab) The obvious workaround is to turn it off for this site, but I've had it active for a while, and it only recently started happening. So I'm assuming it might be a bug.
nobody added the
bug
label 2 weeks ago
nobody added this to the v2.6.19 milestone 2 weeks ago
Owner

Thanks for your report. I was able to reproduce this. The problem was that when the HTML filter modify the HTML source code of this website, a quotation mark was missing. This is caused by the fact that there are different variants to set the charset. As a result the whole source code was not formally correct. There where the charset read and change, I've now improved the detection and replacement.

If you want to test it, you can find a short tutorial here.

Thanks again for your report 👍

Thanks for your report. I was able to reproduce this. The problem was that when the HTML filter modify the HTML source code of this website, a quotation mark was missing. This is caused by the fact that there are different variants to set the charset. As a result the whole source code was not formally correct. There where the charset read and change, I've now improved the detection and replacement. If you want to test it, you can find a short tutorial [here](https://codeberg.org/nobody/LocalCDN/wiki#user-content-5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that). Thanks again for your report 👍
nobody closed this issue 1 week ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.