#62 archiveprogram.github.com renders empty page unless "Filters HTML source code" is checked

Closed
opened 5 months ago by Mikaela · 5 comments
Mikaela commented 5 months ago

Please note the following tips

  • Does the website work after you activate the second switch to filter the HTML source code?

Yes and https://codeberg.org/nobody/LocalCDN/wiki/Blank-websites-or-weird-characters requests reporting it.

  • Is there already an existing issue? (Search for the URL, e.g. "codeberg.org" or "localcdn.org")

Not that I can see.

This appears to be the case.

https://archiveprogram.github.com/

## Please note the following tips * Does the website work after you activate the second switch to filter the HTML source code? Yes and https://codeberg.org/nobody/LocalCDN/wiki/Blank-websites-or-weird-characters requests reporting it. * Is there already an existing issue? (Search for the URL, e.g. "codeberg.org" or "localcdn.org") Not that I can see. * Does the website use a strict SOP? Wiki article: [Broken JavaScript or CSS on some websites](https://codeberg.org/nobody/LocalCDN/wiki/Broken-JavaScript-or-CSS-on-some-websites) This appears to be the case. https://archiveprogram.github.com/
Poster

I can confirm this, it only works with filter HTML source code, this could be a problem in chrome as filter HTML source code does not work.

I can confirm this, it only works with filter HTML source code, this could be a problem in chrome as filter HTML source code does not work.
nobody added the
question/discussion
label 5 months ago
nobody commented 5 months ago
Poster
Owner

Thank you for your report. unbeatable101 is absolutely right. Chromium-based browser doesn't support HTML filters. See Chromium incompatibilities

The website cannot be displayed without jQuery. jQuery is embedded in this line of the HTML source code:

<script src="https://code.jquery.com/jquery-3.3.1.min.js" integrity="sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=" crossorigin="anonymous"></script>

The HTML filter removes the attributes integrity and crossorigin, so that the browser then gets this line:

<script src="https://code.jquery.com/jquery-3.3.1.min.js"></script>

Now it's possible to replace jQuery. 😉

Thank you for your report. unbeatable101 is absolutely right. Chromium-based browser doesn't support HTML filters. See [Chromium incompatibilities](https://codeberg.org/nobody/LocalCDN/wiki/Chromium-incompatibilities) The website cannot be displayed without jQuery. jQuery is embedded in this line of the HTML source code: ``` <script src="https://code.jquery.com/jquery-3.3.1.min.js" integrity="sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=" crossorigin="anonymous"></script> ``` The HTML filter removes the attributes integrity and crossorigin, so that the browser then gets this line: ``` <script src="https://code.jquery.com/jquery-3.3.1.min.js"></script> ``` Now it's possible to replace jQuery. 😉
Poster

So since Chrome is unable to do that, could it be fixed? Or is it just stuck like that.

So since Chrome is unable to do that, could it be fixed? Or is it just stuck like that.
nobody commented 5 months ago
Poster
Owner

In Firefox it works, if you activate the filter manually. That's what the switch is for. 😉

Chromium doesn't allow/support this feature, see here: Issue 487422: WebRequest API: allow extensions to read response body (May 12, 2015)


Edit: That the website is not displayed without jQuery is not due to LocalCDN, but to the website. If you block the connection to code.jquery.com with an adblocker or firewall, the result is the same.

In Firefox it works, if you activate the filter manually. That's what the switch is for. :wink: Chromium doesn't allow/support [this feature](https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/webRequest/filterResponseData), see here: [Issue 487422: WebRequest API: allow extensions to read response body (**May 12, 2015**)](https://bugs.chromium.org/p/chromium/issues/detail?id=487422) --- Edit: That the website is not displayed without jQuery is not due to LocalCDN, but to the website. If you block the connection to `code.jquery.com` with an adblocker or firewall, the result is the same.
nobody commented 5 months ago
Poster
Owner

If anyone has any questions, please reopen the issue.

If anyone has any questions, please reopen the issue.
nobody closed this issue 5 months ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.