Microsoft Edge slow/freezes when loading page that LocalCDN injects into #543

Closed
opened 5 months ago by JJGadgets · 2 comments

I'm on Microsoft Edge (I've grown a reliance on its vertical tabs, sleeping tabs & collections, and I've reduced its telemetry as much as I can, and Firefox/LibreWolf seems to always load all the sites I browse very slowly, like 5-10 seconds on default config/LibreWolf kind of slow, but I digress).

When I have LocalCDN enabled, some sites load really slowly if there are no existing tabs of same domain.

An example would be https://draculatheme.com where there's a significant ~6-10 second delay between pressing the Enter key, and the browser actually showing a responsive interactive page.

The entire of Edge is in fact, frozen, until the loading of the page finishes.

Is this expected behaviour? It seems to happen on every other site, but only just 30 minutes ago have I narrowed the issue down to LocalCDN, so I do not have a comprehensive list of sites that have this issue.

The settings I have enabled (but have no effect when disabled, same issue) are:

  • Display Injection counts on Icon
  • Disable link prefetching
  • Strip metadata from allowed requests
  • Block Google fonts
  • Indicate missing resources on the icon

The extensions I have installed are:

  • 1Password
  • Buster
  • ClearURLs
  • Cookie AutoDelete
  • Dark Reader (I've tested disabling Dark Reader, doesn't improve the issue)
  • HTTPS Everywhere
  • Improve YouTube
  • Privacy Badger (Local learning enabled)
  • Search by Image
  • SponsorBlock for YouTube
  • Universal Bypass
  • WindScribe (disabled this too since it has tracker blocking etc, no difference)
  • uBlock Origin (easy mode, medium/hard mode + generated noop dynamic rules, no difference)

I have attached a video that demonstrates this issue.

I'm on Microsoft Edge (I've grown a reliance on its vertical tabs, sleeping tabs & collections, and I've reduced its telemetry as much as I can, and Firefox/LibreWolf seems to always load all the sites I browse very slowly, like 5-10 seconds on default config/LibreWolf kind of slow, but I digress). When I have LocalCDN enabled, some sites load really slowly if there are no existing tabs of same domain. An example would be https://draculatheme.com where there's a significant ~6-10 second delay between pressing the Enter key, and the browser actually showing a responsive interactive page. The entire of Edge is in fact, frozen, until the loading of the page finishes. Is this expected behaviour? It seems to happen on every other site, but only just 30 minutes ago have I narrowed the issue down to LocalCDN, so I do not have a comprehensive list of sites that have this issue. The settings I have enabled (but have no effect when disabled, same issue) are: * Display Injection counts on Icon * Disable link prefetching * Strip metadata from allowed requests * Block Google fonts * Indicate missing resources on the icon The extensions I have installed are: * 1Password * Buster * ClearURLs * Cookie AutoDelete * Dark Reader (I've tested disabling Dark Reader, doesn't improve the issue) * HTTPS Everywhere * Improve YouTube * Privacy Badger (Local learning enabled) * Search by Image * SponsorBlock for YouTube * Universal Bypass * WindScribe (disabled this too since it has tracker blocking etc, no difference) * uBlock Origin (easy mode, medium/hard mode + generated noop dynamic rules, no difference) I have attached a video that demonstrates this issue.
Owner

Thanks for the perfect description and preparation.

I don't have Windows, but Edge is based on Chromium and I guess it supports all APIs (I'm not sure because I can't find any information about it). Unfortunately, I cannot reproduce the problem with Chromium.

The website https://draculatheme.com/ doesn't use a CDN at all, so LocalCDN can't do anything there. Maybe it loads faster the second time because things are loaded from the cache? In the screenshots you can see the similar loading times on my end. Maybe you can check if this is similar in your case.

I would proceed as follows:

  • If you can create another profile with Edge, then create a new profile and without exiting the browser, test one extension at a time with the same website.
  • Test the extensions one by one with a Chromium-based browser.
  • In both cases, disable the cache and always test the same website at the beginning. This is a small checkbox in the developer options.
Thanks for the perfect description and preparation. I don't have Windows, but Edge is based on Chromium and I guess it supports all APIs (I'm not sure because I can't find any information about it). Unfortunately, I cannot reproduce the problem with Chromium. The website `https://draculatheme.com/` doesn't use a CDN at all, so LocalCDN can't do anything there. Maybe it loads faster the second time because things are loaded from the cache? In the screenshots you can see the similar loading times on my end. Maybe you can check if this is similar in your case. I would proceed as follows: * If you can create another profile with Edge, then create a new profile and without exiting the browser, test one extension at a time with the same website. * Test the extensions one by one with a Chromium-based browser. * In both cases, disable the cache and always test the same website at the beginning. This is a small checkbox in the developer options.
nobody added the
need info
label 5 months ago
Owner

Please reopen this issue if you have more information.

Please reopen this issue if you have more information.
nobody closed this issue 5 months ago
nobody removed the
need info
label 2 months ago
nobody added the
need info
label 2 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.