#53 "Filter HTML Source code" issue

Closed
opened 6 months ago by crssi · 13 comments
crssi commented 6 months ago

Visit https://24ur.com
Using "Filter HTML Source code" produces this effect:
...

But after if I hit CTRL+R to reload a page, it shows as it should:
...

Is it possible to make it work in a way that CTRL+R would not be needed?
The culprit happent only when first visit this domain.
Closing tab, reopen will always work as it should.

I will now close FF and open another link and post another example as reply.

Cheers

Visit https://24ur.com Using "Filter HTML Source code" produces this effect: ... But after if I hit CTRL+R to reload a page, it shows as it should: ... Is it possible to make it work in a way that CTRL+R would not be needed? The culprit happent only when first visit this domain. Closing tab, reopen will always work as it should. I will now close FF and open another link and post another example as reply. Cheers
crssi commented 6 months ago
Poster

Only main page (https://24ur.com) have this problem.
If reopening firefox and visiting directly, for example https://www.24ur.com/novice/tujina/na-hrvaskem-doslej-okoli-50-novih-primerov-koronavirusa-12-oseb-se-je-okuzilo-na-poroki-v-splitu.html, there will be no problem.

Only main page (https://24ur.com) have this problem. If reopening firefox and visiting directly, for example https://www.24ur.com/novice/tujina/na-hrvaskem-doslej-okoli-50-novih-primerov-koronavirusa-12-oseb-se-je-okuzilo-na-poroki-v-splitu.html, there will be no problem.
nobody commented 6 months ago
Poster
Owner

Using “Filter HTML Source code” produces this effect:

Which effect do you mean exactly? (The first image cannot be loaded)

> Using “Filter HTML Source code” produces this effect: Which effect do you mean exactly? (The first image cannot be loaded)
crssi commented 6 months ago
Poster

That is strange. I could see the first image until I have signed up to codeberg.

But here it is, just for to be sure:
image

That is strange. I could see the first image until I have signed up to codeberg. But here it is, just for to be sure: ![image](/attachments/fb798a82-1c70-4165-a14f-329c1fb35e86)
1.3 MiB
nobody commented 6 months ago
Poster
Owner

Thanks for the clarification 👍

I don't have these errors and I can't reproduce them with a fresh profile, see https://www.localcdn.org/dl/53-0.mp4.

Please try the same and report if I have different settings. If the errors don't happen, it's maybe caused by another add-on or your user.js (if you use one).

Thanks for the clarification 👍 I don't have these errors and I can't reproduce them with a fresh profile, see [https://www.localcdn.org/dl/53-0.mp4](https://www.localcdn.org/dl/53-0.mp4). Please try the same and report if I have different settings. If the errors don't happen, it's maybe caused by another add-on or your user.js (if you use one).
crssi commented 6 months ago
Poster

I have no clue why but see the same at my side here:
...

Cheers

I have no clue why but see the same at my side here: ... Cheers
nobody commented 6 months ago
Poster
Owner

Okay, this is very strange. In the source code of the website even UTF-8 is specified as character set, so I don't understand why this error occurs.

Which Firefox version do you have installed?

Okay, this is very strange. In the source code of the website even UTF-8 is specified as character set, so I don't understand why this error occurs. Which Firefox version do you have installed?
crssi commented 6 months ago
Poster

Ah... sorry I haven't specified before... Firefox 78.0.1 (64-bit) on Windows 10 (1909).

Cheers

Ah... sorry I haven't specified before... Firefox 78.0.1 (64-bit) on Windows 10 (1909). Cheers
nobody commented 6 months ago
Poster
Owner

No problem. Thanks for the information 😉

I was able to reproduce the problem. Unfortunately it's not possible to isolate the problem, why this only occurs in certain situations. Unfortunately I can't say why it happens, because the website is encoded in UTF-8 and so no problems should occur at all.

The website does not include frameworks via CDNs. The best thing is to disable the HTML filter for this website.

No problem. Thanks for the information :wink: I was able to reproduce the problem. Unfortunately it's not possible to isolate the problem, why this only occurs in certain situations. Unfortunately I can't say why it happens, because the website is encoded in UTF-8 and so no problems should occur at all. The website does not include frameworks via CDNs. The best thing is to disable the HTML filter for this website.
crssi commented 6 months ago
Poster

Sure... thank you.

If/when I will stumble on some other simmilar, will also report.

Cheers

Sure... thank you. If/when I will stumble on some other simmilar, will also report. Cheers
crssi closed this issue 6 months ago
crssi commented 6 months ago
Poster

Out of curiosity... which software are you using for screen recording?

Thank you, cheers

Out of curiosity... which software are you using for screen recording? Thank you, cheers
crssi commented 6 months ago
Poster
Found more... [https://www.bmw.si/](https://www.bmw.si/) [https://www.bmw-motorrad.si/](https://www.bmw-motorrad.si/) Cheers
crssi commented 6 months ago
Poster

Thinking that it might happen on a sites that are behind some NLB (network load balancer) which doesn't response with UTF8 right away?
Is it possible to force UTF8 until something different is learned?

Cheers

Thinking that it might happen on a sites that are behind some NLB (network load balancer) which doesn't response with UTF8 right away? Is it possible to force UTF8 until something different is learned? Cheers
nobody commented 6 months ago
Poster
Owner

Out of curiosity... which software are you using for screen recording?

I'm using Peek 😉

https://www.bmw.si/ https://www.bmw-motorrad.si/
Thinking that it might happen on a sites that are behind some NLB (network load balancer) which doesn’t response with UTF8 right away?

I don't think so, because in both cases the charset is specified in the HTTP header (and additionally in source code of bmw-motorrad.si)

Anyway, I've already written it here: I'm not a fan of the option to always apply the HTML filter to all websites. Personally, I only use the option where it is necessary.

> Out of curiosity... which software are you using for screen recording? I'm using [Peek](https://github.com/phw/peek) :wink: > https://www.bmw.si/ https://www.bmw-motorrad.si/ > Thinking that it might happen on a sites that are behind some NLB (network load balancer) which doesn’t response with UTF8 right away? I don't think so, because in both cases the charset is specified in the HTTP header (and additionally in source code of bmw-motorrad.si) Anyway, I've already written it [here](https://codeberg.org/nobody/LocalCDN/issues/33): I'm not a fan of the option to always apply the HTML filter to all websites. Personally, I only use the option where it is necessary.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.