Drop down menus not working. xmrig.com | zoro.to/home #470

Closed
opened 2 months ago by Firecatmon · 1 comments

Drop down menus aren't working in these 2 sites I've tried. I've tried with a clean firefox profile without addons or edited about:config and stuff but the issue persists. Filter source code doesn't fix either either

The below images show what should show after clicking the button. But with localCDNs enabled, it doesn't show

"pools" https://xmrig.com/wizard#pools
image

After the profile image ("Q" in this case) https://zoro.to/home (after signing in)
image

Drop down menus aren't working in these 2 sites I've tried. I've tried with a clean firefox profile without addons or edited about:config and stuff but the issue persists. Filter source code doesn't fix either either The below images show what *should* show after clicking the button. But with localCDNs enabled, it doesn't show "pools" https://xmrig.com/wizard#pools ![image](/attachments/60281244-d984-4433-b754-cdbf66086dd0) After the profile image ("Q" in this case) https://zoro.to/home (after signing in) ![image](/attachments/f735cccb-be22-4601-8586-cb0a1bbe2261)
nobody referenced this issue from a commit 2 months ago
Owner

Thanks for your great report 👍

Normally for Bootstrap v4.x and v5.x the file bootstrap.bundle.min.js should be included instead of bootstrap.min.js. Through the audit script, the normal variant (bootstrap.min.js) was downloaded for both versions. This file also contains Popper (docs). This missing framework is the reason why both websites are not working.

Note: This change is part of the v2.6.8 release and will be available in about 2 weeks. The last version (v2.6.7) is already in Mozilla's queue since yesterday and the release may need a few days.


If you want to test this, you can find a how-to here.

Thanks for your great report 👍 Normally for Bootstrap v4.x and v5.x the file `bootstrap.bundle.min.js` should be included instead of `bootstrap.min.js`. Through the audit script, the normal variant (`bootstrap.min.js`) was downloaded for both versions. This file also contains `Popper` ([docs](https://getbootstrap.com/docs/4.6/getting-started/introduction/#bundle)). This missing framework is the reason why both websites are not working. Note: This change is part of the v2.6.8 release and will be available in about 2 weeks. The last version (v2.6.7) is already in Mozilla's queue since yesterday and the release may need a few days. --- If you want to test this, you can find a how-to [here](https://codeberg.org/nobody/LocalCDN/wiki#user-content-5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that).
nobody added the
bug
label 2 months ago
nobody added this to the v2.6.8 milestone 2 months ago
nobody closed this issue 2 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.