[Multiple websites] Tab crash with firefox beta 79.0b1 and 80.0a1 #46

Closed
opened 1 year ago by patriki · 7 comments
patriki commented 1 year ago

Hello,

Does the website work after you activate the second switch to filter the HTML source code? NO
Is there already an existing issue? (Search for the URL, e.g. "codeberg.org" or "localcdn.de") NO


Previous firefox beta 78 & localcdn worked fine before.
Just updated FF beta 78 to beta 79, localcdn makes gearslutz tab crashing.

https://www.gearslutz.com/board/electronic-music-instruments-and-electronic-music-production/

Now, the site doesn't load completely, and clicking on a link on the page crashes the tab. Firefox then opens a page to provide details and send a report.

Whitelisting gearslutz.com solves the problem, there are 2 cdn on this website, (see image).

Thanks for your help and for this addon

Hello, Does the website work after you activate the second switch to filter the HTML source code? **NO** Is there already an existing issue? (Search for the URL, e.g. "codeberg.org" or "localcdn.de") **NO** ------------------------------ Previous firefox beta 78 & localcdn worked fine before. Just updated FF beta 78 to beta 79, localcdn makes gearslutz tab crashing. https://www.gearslutz.com/board/electronic-music-instruments-and-electronic-music-production/ Now, the site doesn't load completely, and clicking on a link on the page crashes the tab. Firefox then opens a page to provide details and send a report. Whitelisting gearslutz.com solves the problem, there are 2 cdn on this website, (see image). Thanks for your help and for this addon
Owner

Thanks for your report 👍

Looks like a Firefox issue 🤔 The problem was reproducible with FF79.0b1 and FF80.0a1, so I created two bug reports:

Thanks for your report 👍 Looks like a Firefox issue 🤔 The problem was reproducible with FF79.0b1 and FF80.0a1, so I created two bug reports: * [FF79.0b1 | Crash in mozilla::SharedStyleSheetCache::CancelLoadsForLoader](https://bugzilla.mozilla.org/show_bug.cgi?id=1649555) * [FF80.0a1 | Crash in mozilla::css::StreamLoader::~StreamLoader](https://bugzilla.mozilla.org/show_bug.cgi?id=1649560)
nobody changed title from gearslutz.com tab crash with firefox beta 79.1 to gearslutz.com tab crash with firefox beta 79.0b1 and 80.0a1 1 year ago
Poster

I've had the same issues on other sites, so we'll see later how things evolve with this firefox beta.
Thanks again.

I've had the same issues on other sites, so we'll see later how things evolve with this firefox beta. Thanks again.
Owner

I don't think more links are necessary, but maybe this will increase the pressure on Mozilla. 😉

Would you like to post the pages here (and I'll copy them into the issue on Bugzilla) or would you like to directly append them there yourself?

I don't think more links are necessary, but maybe this will increase the pressure on Mozilla. :wink: Would you like to post the pages here (and I'll copy them into the issue on Bugzilla) or would you like to directly append them there yourself?
Poster

No, it's not necessary, if the bug is fixed, it will be for all sites, right? Well, I hope so. 🤞
Otherwise, I can go directly to bugzilla...

No, it's not necessary, if the bug is fixed, it will be for all sites, right? Well, I hope so. 🤞 Otherwise, I can go directly to bugzilla...
Owner

if the bug is fixed, it will be for all sites, right?

I hope so.

Maybe it's possible that only nightly and beta versions are affected. I find this issue and code changes. There is also another issue, but I have no access to this one. 😕

> if the bug is fixed, it will be for all sites, right? I hope so. Maybe it's possible that only nightly and beta versions are affected. I find this [issue](https://bugzilla.mozilla.org/show_bug.cgi?id=1615832) and [code changes](https://phabricator.services.mozilla.com/rMOZILLACENTRAL7c9ac7d5bef462ee60602a9c90a53dc3ff821e83). There is also another [issue](https://bugzilla.mozilla.org/show_bug.cgi?id=1649728), but I have no access to this one. :confused:
nobody changed title from gearslutz.com tab crash with firefox beta 79.0b1 and 80.0a1 to [Multiple websites] Tab crash with firefox beta 79.0b1 and 80.0a1 1 year ago
Poster

Hi,

Well the last beta 5 of FF79 seems to have solved the problem. I've browsed a few minutes on gearslutz without any tab crashes! 👍

Cheers

Hi, Well the last beta 5 of FF79 seems to have solved the problem. I've browsed a few minutes on gearslutz without any tab crashes! 👍 Cheers
Owner

Great, thanks for the info. 👍

So the problem was Firefox and not LocalCDN.

Great, thanks for the info. 👍 So the problem was Firefox and not LocalCDN.
nobody closed this issue 1 year ago
nobody added the
firefox-bug
label 7 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.