Bug with HTML Filter and unquoted img src attribute #370

Closed
opened 7 months ago by mendi589 · 4 comments

With the HTML Filter enabled, an html page that looks like this:

<img src=https://doesnt.matter/image1.png>
<img src=https://doesnt.matter/image2.png>
<img src=https://doesnt.matter/image3.png>

Will keep loading forever, and nothing happens. Only works with the HTML Filter disabled.

I tested by hosting locally an html file containing exactly those 3 lines above. It does not matter if the images exist or not. My guess is that the problem lies on the value of the 'src' attribute being unquoted.

With the HTML Filter enabled, an html page that looks like this: ``` <img src=https://doesnt.matter/image1.png> <img src=https://doesnt.matter/image2.png> <img src=https://doesnt.matter/image3.png> ``` Will keep loading forever, and nothing happens. Only works with the HTML Filter disabled. I tested by hosting locally an html file containing exactly those 3 lines above. It does not matter if the images exist or not. My guess is that the problem lies on the value of the 'src' attribute being unquoted.
Owner

The HTML filter should only work on script (<script...) and link (<link...) elements (manipulate-dom.js#L118).

I can't reproduce this at the moment.

  • Which exact browser version are you using? (Firefox stable/nightly/beta),
  • Can you attach the whole HTML file here?
  • How do you call the HTML file? Local webservice (e.g. XAMPP) or as file (in the address line file:///)?
The HTML filter should only work on script (`<script...`) and link (`<link...`) elements ([manipulate-dom.js#L118](https://codeberg.org/nobody/LocalCDN/src/branch/main/core/manipulate-dom.js#L118)). I can't reproduce this at the moment. * Which exact browser version are you using? (Firefox stable/nightly/beta), * Can you attach the whole HTML file here? * How do you call the HTML file? Local webservice (e.g. XAMPP) or as file (in the address line `file:///`)?
Poster
  • Firefox 87.0 (64-bit)
  • Attached
  • I am just using python.exe -m http.server and then I load it with http://127.0.0.1:8000/test.html
* Firefox 87.0 (64-bit) * Attached * I am just using `python.exe -m http.server` and then I load it with `http://127.0.0.1:8000/test.html`
Poster

I just updated LocalCDN from v2.6.4 to v2.6.5 and now this does not happen anymore. I spent 1 hour trying to replicate this with a new profile without realizing LocalCDN was updated in the meantime. :)

I just updated LocalCDN from v2.6.4 to v2.6.5 and now this does not happen anymore. I spent 1 hour trying to replicate this with a new profile without realizing LocalCDN was updated in the meantime. :)
Owner

Oh, sorry, I've also already tested with v2.6.5. Then it was related to this change: #340

Oh, sorry, I've also already tested with v2.6.5. Then it was related to this change: #340
nobody added the
duplicate
label 7 months ago
nobody closed this issue 7 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.