Bluebird.js missing #342

Closed
opened 6 months ago by TheMageKing · 7 comments

Bluebird is a javscript library used in VAMS, the system for distributing COVID vaccines in the US. It is a fairly compact javascript library for promices and other asynchronous nonsense. It includes a "core" and a "full": the minified "full" is only 80 KB, so I think it's a reasonably good addition to the extension.

Bluebird is a javscript library used in VAMS, the system for distributing COVID vaccines in the US. It is a fairly compact javascript library for promices and other asynchronous nonsense. It includes a "core" and a "full": the minified "full" is only 80 KB, so I think it's a reasonably good addition to the extension.
Poster

Also, I couldn't easily find clear docs for how to add a new framework. Perhaps a CONTRIBUTING.md file is needed?

Also, I couldn't easily find clear docs for how to add a new framework. Perhaps a CONTRIBUTING.md file is needed?
nobody referenced this issue from a commit 6 months ago
Owner

Thanks for your report 👍

I've added it. Is there a publicly accessible website to test this with? If not, you will have to test it yourself: https://codeberg.org/nobody/LocalCDN/wiki#5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that

Also, I couldn't easily find clear docs for how to add a new framework. Perhaps a CONTRIBUTING.md file is needed?

Very good idea 👍 👍 👍 I'll write something about that in the next days and put it in the repo.

Thanks for your report 👍 I've added it. Is there a publicly accessible website to test this with? If not, you will have to test it yourself: https://codeberg.org/nobody/LocalCDN/wiki#5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that > Also, I couldn't easily find clear docs for how to add a new framework. Perhaps a CONTRIBUTING.md file is needed? Very good idea 👍 👍 👍 I'll write something about that in the next days and put it in the repo.
nobody added the
missing framework/mapping
label 6 months ago
nobody added this to the v2.6.5 milestone 6 months ago
nobody added the
documentation
label 6 months ago
Poster

Couldn't find a public site, and I don't know how I would do that: but the request wasn't blocked. VAMS only uses the core: that might be it?

Request headers:

GET /bluebird/3.5.0/bluebird.core.min.js HTTP/1.1
Host: cdn.jsdelivr.net
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0
Accept: /
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate, br
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache

Couldn't find a public site, and I don't know how I would do that: but the request wasn't blocked. VAMS only uses the core: that might be it? Request headers: GET /bluebird/3.5.0/bluebird.core.min.js HTTP/1.1 Host: cdn.jsdelivr.net User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0 Accept: */* Accept-Language: en-US,en;q=0.5 Accept-Encoding: gzip, deflate, br Connection: keep-alive Pragma: no-cache Cache-Control: no-cache
Poster

Oh, THATS fun. The actual request is done as a script tag inside a google maps iFrame. That might be letting it bypass the filtering.

Oh, THATS fun. The actual request is done as a script tag inside a google maps iFrame. That might be letting it bypass the filtering.
Owner

Ah okay, that's caused by the mapping. I've added that for cdn.jsdelivr.net.

Ah okay, that's caused by the mapping. I've added that for `cdn.jsdelivr.net`.
Poster

Confirmed, all's well

Confirmed, all's well
TheMageKing closed this issue 6 months ago
Owner

Great, thanks for testing 👍

Great, thanks for testing 👍
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.