Add missing frameworks/mappings #332

Closed
opened 3 months ago by planeted · 9 comments

I found this website while searching for a reference link for the above two. It looks like a decent enough source to add not only the frameworks that are reported by the community, but several unknown ones too. Though a complete addition might not be efficient in terms of memory consumption, the criteria which selects the frameworks to be added, can be modified on the go.

Edit : I just went through my log and found several others,

  • maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap-theme.min.css
  • cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/fonts//fontawesome-webfont.woff2
  • cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/semantic.min.css
  • cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/themes/default/assets/fonts/icons.woff2
  • cdn.jsdelivr.net/docsearch.js/1/docsearch.min.css
  • cdn.jsdelivr.net/docsearch.js/1/docsearch.min.js
  • unpkg.com/vanilla-back-to-top@7.1.14/dist/vanilla-back-to-top.min.js
  • cdnjs.cloudflare.com/ajax/libs/feather-icons/4.28.0/feather.min.js
* Babel Standalone Framework: https://cdnjs.cloudflare.com/ajax/libs/babel-standalone/6.24.0/babel.min.js (this is the version I encountered, it might not be the latest) Link: https://www.cdnpkg.com/babel-standalone * Jasny Bootstrap Framework: https://cdnjs.cloudflare.com/ajax/libs/jasny-bootstrap/3.1.3/js/jasny-bootstrap.min.js (this is the version I encountered, it might not be the latest) Link: https://www.cdnpkg.com/jasny-bootstrap I found [this](https://www.cdnpkg.com/) website while searching for a reference link for the above two. It looks like a decent enough source to add not only the frameworks that are reported by the community, but several unknown ones too. Though a complete addition might not be efficient in terms of memory consumption, the criteria which selects the frameworks to be added, can be modified on the go. Edit : I just went through my log and found several others, * maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap-theme.min.css * cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/fonts//fontawesome-webfont.woff2 * cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/semantic.min.css * cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/themes/default/assets/fonts/icons.woff2 * cdn.jsdelivr.net/docsearch.js/1/docsearch.min.css * cdn.jsdelivr.net/docsearch.js/1/docsearch.min.js * unpkg.com/vanilla-back-to-top@7.1.14/dist/vanilla-back-to-top.min.js * cdnjs.cloudflare.com/ajax/libs/feather-icons/4.28.0/feather.min.js
Owner

Do you have a website that uses this? I can't test that otherwise.

  • cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/fonts//fontawesome-webfont.woff2
  • cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/themes/default/assets/fonts/icons.woff2

At the moment, fonts cannot be forwarded directly, see here

Do you have a website that uses this? I can't test that otherwise. > * cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/fonts//fontawesome-webfont.woff2 > * cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/themes/default/assets/fonts/icons.woff2 At the moment, fonts cannot be forwarded directly, see [here](https://codeberg.org/nobody/LocalCDN/issues/308)
Poster

At the moment, fonts cannot be forwarded directly

Yes, I did encounter NS_ERROR_DOM_BAD_URI several times. But I think it only applies to Google fonts. Btw, the bugzilla issue you created has been closed and marked resolved.

cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/ is used by https://www.cdnpkg.com/

But I think it only applies to Google fonts.

ig not. I just had two requests thrown the same error.

https://stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css & https://stackpath.bootstrapcdn.com/bootstrap/4.5.2/css/bootstrap.min.css

> At the moment, fonts cannot be forwarded directly Yes, I did encounter `NS_ERROR_DOM_BAD_URI` several times. But I think it only applies to Google fonts. Btw, the bugzilla issue you created has been closed and marked resolved. `cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.13/` is used by `https://www.cdnpkg.com/` > But I think it only applies to Google fonts. ig not. I just had two requests thrown the same error. `https://stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css` & `https://stackpath.bootstrapcdn.com/bootstrap/4.5.2/css/bootstrap.min.css`
nobody referenced this issue from a commit 3 months ago
nobody added the
missing framework/mapping
label 3 months ago
nobody added this to the v2.6.5 milestone 3 months ago
Owner

Yes, I did encounter NS_ERROR_DOM_BAD_URI several times. But I think it only applies to Google fonts.

No, this is valid for all fonts that are to be redirected directly. From https://example.com/font.woff to moz-extension://random-uuid/resources/.../font.woff. Doesn't matter if example.com is Google Fonts, Font Awesome, Boostrap or anything else.

the bugzilla issue you created has been closed and marked resolved

It was marked as RESOLVED DUPLICATE of bug 1694679. I'll add this to the other issue.

https://stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css

Already supported: mapping.js, resources.js, targets.js

https://stackpath.bootstrapcdn.com/bootstrap/4.5.2/css/bootstrap.min.css

Already supported: mapping.js, resources.js, targets.js

Babel Standalone

I don't know where this is needed and don't see any differences.

semantic-ui
Jasny Bootstrap

Added 😉

> Yes, I did encounter NS_ERROR_DOM_BAD_URI several times. But I think it only applies to Google fonts. No, this is valid for all fonts that are to be redirected directly. From `https://example.com/font.woff` to `moz-extension://random-uuid/resources/.../font.woff`. Doesn't matter if `example.com` is Google Fonts, Font Awesome, Boostrap or anything else. > the bugzilla issue you created has been closed and marked resolved It was marked as **RESOLVED DUPLICATE of bug [1694679](https://bugzilla.mozilla.org/show_bug.cgi?id=1694679)**. I'll add this to the other issue. > `https://stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css` Already supported: [mapping.js](https://codeberg.org/nobody/LocalCDN/src/commit/d2506369ab5e7cf24633899a8887b1ae48840d75/core/mappings.js#L881), [resources.js](https://codeberg.org/nobody/LocalCDN/src/commit/d2506369ab5e7cf24633899a8887b1ae48840d75/core/resources.js#L416), [targets.js](https://codeberg.org/nobody/LocalCDN/src/commit/d2506369ab5e7cf24633899a8887b1ae48840d75/modules/internal/targets.js#L252) > `https://stackpath.bootstrapcdn.com/bootstrap/4.5.2/css/bootstrap.min.css` Already supported: [mapping.js](https://codeberg.org/nobody/LocalCDN/src/commit/d2506369ab5e7cf24633899a8887b1ae48840d75/core/mappings.js#L880), [resources.js](https://codeberg.org/nobody/LocalCDN/src/commit/d2506369ab5e7cf24633899a8887b1ae48840d75/core/resources.js#L217), [targets.js](https://codeberg.org/nobody/LocalCDN/src/commit/d2506369ab5e7cf24633899a8887b1ae48840d75/modules/internal/targets.js#L173) > Babel Standalone I don't know where this is needed and don't see any differences. > semantic-ui > Jasny Bootstrap Added :wink:
Poster

Added 😉

Thanks.

Upon opening cupwire.com I see a request to https://fonts.googleapis.com/css?family=Muli:400,400i,700,700i,800. Some change required?

> Added 😉 Thanks. Upon opening `cupwire.com` I see a request to `https://fonts.googleapis.com/css?family=Muli:400,400i,700,700i,800`. Some change required?
nobody referenced this issue from a commit 3 months ago
nobody referenced this issue from a commit 3 months ago
Owner

Some change required?

If you have blocked Google fonts in LcoalCDN, then these requests should also be blocked.


I noticed that a request to the CSS file is not blocked because the URL has a different structure. (fonts.gstatic.com/s/muli/v22/...)

> Some change required? If you have blocked Google fonts in LcoalCDN, then these requests should also be blocked. --- I noticed that a request to the CSS file is not blocked because the URL has a different structure. (`fonts.gstatic.com/s/muli/v22/...`)
Poster

URL has a different structure

Yes, thank you. There are two more similar structures to be blocked, can be seen at https://tny.so/

https://fonts.googleapis.com/css?family=Poppins:200,300,400,500,600,700,800&display=swap & https://fonts.googleapis.com/css?family=Caveat:400,700&display=swap

And the previously shown cdnjs.cloudflare.com/ajax/libs/feather-icons/4.28.0/feather.min.js can be seen here.

> URL has a different structure Yes, thank you. There are two more similar structures to be blocked, can be seen at `https://tny.so/` `https://fonts.googleapis.com/css?family=Poppins:200,300,400,500,600,700,800&display=swap` & `https://fonts.googleapis.com/css?family=Caveat:400,700&display=swap` And the previously shown `cdnjs.cloudflare.com/ajax/libs/feather-icons/4.28.0/feather.min.js` can be seen [here](https://tny.so/6dR5vx3#).
nobody referenced this issue from a commit 3 months ago
Owner

There are two more similar structures to be blocked, can be seen at https://tny.so

Both URLs are already catched by the regular expressions: b6e188f0cc

feather-icons

Added 😉

(It would be good if you create a separate issue for each website/framework and include a specific topic)

> There are two more similar structures to be blocked, can be seen at https://tny.so Both URLs are already catched by the regular expressions: https://codeberg.org/nobody/LocalCDN/commit/b6e188f0cc2ec7a68f8e3d097144f86482a78fbc > feather-icons Added 😉 (It would be good if you create a separate issue for each website/framework and include a specific topic)
Poster

Both URLs are already catched by the regular expressions: b6e188f0cc

Oh. Didn't realize that. I just tested the v2.6.5 and yes they are catched.

It would be good if you create a separate issue for each website/framework and include a specific topic

🙈 I really should. Especially since there's no search in repository feature like on Github here.

If docsearch.js is essential, I'll reopen this issue, until then all are covered ig?

> Both URLs are already catched by the regular expressions: b6e188f0cc Oh. Didn't realize that. I just tested the v2.6.5 and yes they are catched. > It would be good if you create a separate issue for each website/framework and include a specific topic 🙈 I really should. Especially since there's no search in repository feature like on Github here. If `docsearch.js` is essential, I'll reopen this issue, until then all are covered ig?
Owner

there's no search in repository feature like on Github here

Yes, the search function here is very simple.

If docsearch.js is essential, I'll reopen this issue, until then all are covered ig?

Exactly 👍

> there's no search in repository feature like on Github here Yes, the search function here is very simple. > If docsearch.js is essential, I'll reopen this issue, until then all are covered ig? Exactly :+1:
nobody closed this issue 3 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.