[rokups.github.io] Missing resources #311

Closed
opened 4 months ago by Paba22 · 6 comments
Paba22 commented 4 months ago

The website is entirely blank when LocalCDN is enabled. After disabling it everything loads fine.

So I tried to find out why it doesn't work, but I'm not sure if I'm doing this correctly. After checking "Indicate missing resources on the icon", the icon changed color to yellow and checking the logs there is a resource highlited in yellow and it's also not redirected anywhere. The resource is:
yandex.st/highlightjs/7.3/highlight.min.js

I have also attached an image of the LocalCDN log page.

Please let me know if I'm doing this correctly and this is the missing resource, that causes the website to break.

The website is entirely blank when LocalCDN is enabled. After disabling it everything loads fine. So I tried to find out why it doesn't work, but I'm not sure if I'm doing this correctly. After checking "Indicate missing resources on the icon", the icon changed color to yellow and checking the logs there is a resource highlited in yellow and it's also not redirected anywhere. The resource is: yandex.st/highlightjs/7.3/highlight.min.js I have also attached an image of the LocalCDN log page. Please let me know if I'm doing this correctly and this is the missing resource, that causes the website to break.
nobody added the
missing framework/mapping
label 4 months ago
nobody added this to the v2.6.4 milestone 4 months ago
Owner

Please let me know if I'm doing this correctly and this is the missing resource, that causes the website to break.

That's perfect 👍 👍 👍

Looks like version 9.18.3 is backward compatible to 7.3.

If you want to test it: https://codeberg.org/nobody/LocalCDN/wiki#user-content-5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that

> Please let me know if I'm doing this correctly and this is the missing resource, that causes the website to break. That's perfect :+1: :+1: :+1: Looks like version 9.18.3 is backward compatible to 7.3. If you want to test it: https://codeberg.org/nobody/LocalCDN/wiki#user-content-5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that
nobody closed this issue 4 months ago
Poster

I've tried the newest version on a fresh profile and it seems like highlight.js is loaded now, but the page still remains entirely blank. I've attached a screenshot.

I've tried the newest version on a fresh profile and it seems like highlight.js is loaded now, but the page still remains entirely blank. I've attached a screenshot.
Paba22 reopened this issue 4 months ago
Owner

You're right. The requested resource Bootstrap v3.0.0 cannot be upgraded to v3.3.7 because it's not compatible with the requested jQuery verison 1.8.3.

I've added Bootstrap 3.0.0 so that the website should be displayed. Thanks 👍

You're right. The requested resource Bootstrap v3.0.0 cannot be upgraded to v3.3.7 because it's not compatible with the requested jQuery verison 1.8.3. I've added Bootstrap 3.0.0 so that the website should be displayed. Thanks 👍
nobody referenced this issue from a commit 4 months ago
Poster

Nice! Everything seems to work fine now. Thank you very much. Now I've only got one last question regarding reporting missing resources in the future. In the wiki it says about which frameworks may be included:

The framework must also be useful and necessary for the function of a website.

Do I understand this correctly, that this means I should open an issue only if I find a missing functionality on a website and not every time the icon lights up yellow?

Have a nice day and thank you for your time!

Nice! Everything seems to work fine now. Thank you very much. Now I've only got one last question regarding reporting missing resources in the future. In the wiki it says about which frameworks may be included: > The framework must also be useful and necessary for the function of a website. Do I understand this correctly, that this means I should open an issue only if I find a missing functionality on a website and not every time the icon lights up yellow? Have a nice day and thank you for your time!
Owner

Everything seems to work fine now.

Great 😊

Do I understand this correctly, that this means I should open an issue only if I find a missing functionality on a website and not every time the icon lights up yellow?

You can always open an issue if you have a question or are unsure 😉

The yellow icon is currently a test. Basically, LocalCDN is supposed to make a website usable. If you notice that something behaves strangely or buttons don't work then this can be an indication of a missing resource. (or a failed upgrade if resources are not backward compatible).

> Everything seems to work fine now. Great 😊 > Do I understand this correctly, that this means I should open an issue only if I find a missing functionality on a website and not every time the icon lights up yellow? You can always open an issue if you have a question or are unsure 😉 The yellow icon is currently a test. Basically, LocalCDN is supposed to make a website usable. If you notice that something behaves strangely or buttons don't work then this can be an indication of a missing resource. (or a failed upgrade if resources are not backward compatible).
Poster

Ok, guess I'll just open an issue when I find something again.

Thank you again for your help.

Ok, guess I'll just open an issue when I find something again. Thank you again for your help.
Paba22 closed this issue 4 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.