#30 Just a sample page where "Filters HTML source code" has positive impact

Closed
opened 10 months ago by crssi · 4 comments
crssi commented 10 months ago
https://www.abc15.com/news/region-phoenix-metro/central-phoenix/thousands-of-bats-flocking-to-phoenix-bat-cave
9.1 KiB
crssi commented 10 months ago
Poster

I wonder is there a reason not to have this option enabled by default?

Cheers and thank you for your wonderfull work 😄

I wonder is there a reason not to have this option enabled by default? Cheers and thank you for your wonderfull work :smile:
nobody commented 10 months ago
Owner

Yes, indeed there was a reason for that. 😉

With this option the HTML source code is read, modified (some parts removed*) and "written back" by LocalCDN to the browser tab. The last step is sometimes incorrect, because TextEncode() supports only the UTF-8 charset.

So if a website was originally written with a different charset (e.g. ISO-8859-1), LocalCDN has to convert the HTML source code. The problem is when the web server has to process user input (e.g. in a forum), because then display errors occur due to the different encoding. This does not change the function of the LocalCDN, but it looks ugly. Problems could also occur if these entries are to end up in a database.

Therefore, this feature is optional and can be activated if required (in cases when certain parts of the HTML source code prevent the exchange).

*A part that must be removed is called integrity and checks with a checksum if the loaded framework has been changed. Since LocalCDN bundles several versions, the checksum will rarely match. LocalCDN must therefore remove these parts so that the CDN frameworks can be replaced.

Yes, indeed there was a reason for that. :wink: With this option the HTML source code is read, modified (some parts removed*) and "written back" by LocalCDN to the browser tab. The last step is sometimes incorrect, because TextEncode() supports only the UTF-8 charset. So if a website was originally written with a different charset (e.g. ISO-8859-1), LocalCDN has to convert the HTML source code. The problem is when the web server has to process user input (e.g. in a forum), because then display errors occur due to the different encoding. This does not change the function of the LocalCDN, but it looks ugly. Problems could also occur if these entries are to end up in a database. Therefore, this feature is optional and can be activated if required (in cases when certain parts of the HTML source code prevent the exchange). **A part that must be removed is called integrity and checks with a checksum if the loaded framework has been changed. Since LocalCDN bundles several versions, the checksum will rarely match. LocalCDN must therefore remove these parts so that the CDN frameworks can be replaced.*
crssi commented 10 months ago
Poster

Thank you for a thorough and perfect explanation.

OT: I guess christmass might come much earlier this year 😄: https://bugzilla.mozilla.org/show_bug.cgi?id=1419459#c11

Thank you for a thorough and perfect explanation. OT: I guess christmass might come much earlier this year :smile:: https://bugzilla.mozilla.org/show_bug.cgi?id=1419459#c11
nobody commented 10 months ago
Owner

You're welcome.

I would have been very happy about that. Unfortunately, it looks like algo12 is "only" a normal user 😕

Btw this is also a good example where "Filters HTML source code" is necessary: https://forum.xda-developers.com/

You're welcome. I would have been very happy about that. Unfortunately, it looks like algo12 is "only" a normal user :confused: Btw this is also a good example where "Filters HTML source code" is necessary: https://forum.xda-developers.com/
nobody added the
documentation
label 10 months ago
nobody closed this issue 10 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.