HTML Filtering breaks Font Awesome (monkeytype.com) #295

Closed
opened 9 months ago by Yellowsink · 5 comments

I have encountered this on multiple sites, but https://monkeytype.com is a good example. When HTML filtering is enabled, Font-Awesome (CSS) breaks.

HTML filtering enabled (arrow shows where icon should go)
image

HTML filtering disabled
image

I have encountered this on multiple sites, but https://monkeytype.com is a good example. When HTML filtering is enabled, Font-Awesome (CSS) breaks. HTML filtering enabled (arrow shows where icon should go) ![image](/attachments/271f0da3-a471-409f-8322-af6a241e12ee) HTML filtering disabled ![image](/attachments/58d1e8f9-965a-4dc2-8573-4aa8ed67210c)
Owner

Many thanks for your report 👍 👍

Unfortunately, I cannot reproduce this. In the HTML code there is only one line with crossorigin/integrity attributes. In this line (Font Awesome) the attributes are removed correctly.

HTML filter disabled:
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.1/css/all.min.css" integrity="sha512-+4zCK9k+qNFUR5X+cKL9EIR+ZOhtIloNl9GIKS57V1MyNsYpYcUrUeQc9vNfzsWfV28IaLL3i96P9sdNyeRssA==" crossorigin="anonymous" />

HTML filter enabled:
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.1/css/all.min.css" />

You can try a new Firefox profile (about:profiles -> Wiki) to see if the problem occurs there as well.

Can you give me another website where this happens?

Many thanks for your report 👍 👍 Unfortunately, I cannot reproduce this. In the HTML code there is only one line with crossorigin/integrity attributes. In this line (Font Awesome) the attributes are removed correctly. HTML filter disabled: `<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.1/css/all.min.css" integrity="sha512-+4zCK9k+qNFUR5X+cKL9EIR+ZOhtIloNl9GIKS57V1MyNsYpYcUrUeQc9vNfzsWfV28IaLL3i96P9sdNyeRssA==" crossorigin="anonymous" />` HTML filter enabled: `<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.1/css/all.min.css" />` You can try a new Firefox profile (`about:profiles` -> [Wiki](https://codeberg.org/nobody/LocalCDN/wiki#user-content-5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that)) to see if the problem occurs there as well. Can you give me another website where this happens?
Poster

I am exceptionally confused now. I disabed and re-enabled LocalCDN on monkeytype and it fixed it. Also same trick appeared to work for player svg icons on yugenani.me disappearing.

But it's fixed I guess.

I am exceptionally confused now. I disabed and re-enabled LocalCDN on monkeytype and it fixed it. Also same trick appeared to work for player svg icons on yugenani.me disappearing. But it's fixed I guess.
Yellowsink closed this issue 9 months ago
Owner

Hmm, okay that sounds strange. Disable and enable is not a good solution.

Have you tested this with a fresh Firefox profile?

Hmm, okay that sounds strange. Disable and enable is not a good solution. Have you tested this with a fresh Firefox profile?
Poster

No i haven't yet

No i haven't yet
Owner

If this occurs again, it's necessary to analyze this in detail:

  • Which Firefox version (Normal, Beta, Nightly)?
  • What other extensions are installed?
  • Is there a user.js?

Feel free to reopen this issue

If this occurs again, it's necessary to analyze this in detail: * Which Firefox version (Normal, Beta, Nightly)? * What other extensions are installed? * Is there a user.js? Feel free to reopen this issue
nobody added the
observation
label 9 months ago
nobody added
need info
and removed
observation
labels 9 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.