Region dropdown menu doesn't work on 2fa.directory website #286

Closed
opened 7 months ago by emlimap · 2 comments
emlimap commented 7 months ago

Website: https://2fa.directory/
Browser: Firefox 87.0b3
LocalCDN version: 2.6.1

The regions dropdown in the top menu bar doesn't work when localcdn is enabled. Irrespective of whether Filter HTML source option is enabled or not.

Looking at web console, I do see the following errors. It could be CORS related errors and one error about Jquery need to be loaded before Jquery boostrap is loaded.

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/font-awesome/5.15.2/css/all.min.css. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/jets/0.14.1/jets.min.jsm. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/jquery/3.5.1/jquery.min.jsm. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/vanilla-lazyload/17.3.0/lazyload.min.jsm. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.12.1/css/all.min.css. (Reason: CORS request did not succeed).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/jets/0.14.1/jets.min.js. (Reason: CORS request did not succeed).
None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js. (Reason: CORS request did not succeed).
None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.jsdelivr.net/npm/vanilla-lazyload@15.1.1/dist/lazyload.min.js. (Reason: CORS request did not succeed).
None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/jquery/3.5.1/jquery.min.jsm. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js. (Reason: CORS request did not succeed).
None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/vanilla-lazyload/17.3.0/lazyload.min.jsm. (Reason: CORS request not http).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.jsdelivr.net/npm/vanilla-lazyload@15.1.1/dist/lazyload.min.js. (Reason: CORS request did not succeed).
None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory
Uncaught TypeError: Bootstrap's JavaScript requires jQuery. jQuery must be included before Bootstrap's JavaScript.
    jQueryDetection https://2fa.directory/js/bootstrap.min.js:5
    <anonymous> https://2fa.directory/js/bootstrap.min.js:5
    <anonymous> https://2fa.directory/js/bootstrap.min.js:5
    <anonymous> https://2fa.directory/js/bootstrap.min.js:5
bootstrap.min.js:5:3633
Uncaught ReferenceError: jQuery is not defined
    <anonymous> https://2fa.directory/js/popup.js:1
popup.js:1:1
Uncaught ReferenceError: $ is not defined
    <anonymous> https://2fa.directory/js/main.js:1
main.js:1:1
Uncaught ReferenceError: $ is not defined
    <anonymous> https://2fa.directory/js/social-media.js:1
social-media.js:1:1
Uncaught ReferenceError: $ is not defined
    <anonymous> https://2fa.directory/js/search.js:1
search.js:1:1
    <anonymous> https://2fa.directory/js/search.js:1

Steps to reproduce:

  1. Visit https://2fa.directory/
  2. Click on region dropdown and select a region.
  3. once the region page loads, the region dropdown now locks
Website: https://2fa.directory/ Browser: Firefox 87.0b3 LocalCDN version: 2.6.1 The regions dropdown in the top menu bar doesn't work when localcdn is enabled. Irrespective of whether Filter HTML source option is enabled or not. Looking at web console, I do see the following errors. It could be CORS related errors and one error about Jquery need to be loaded before Jquery boostrap is loaded. ``` Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/font-awesome/5.15.2/css/all.min.css. (Reason: CORS request not http). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/jets/0.14.1/jets.min.jsm. (Reason: CORS request not http). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/jquery/3.5.1/jquery.min.jsm. (Reason: CORS request not http). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/vanilla-lazyload/17.3.0/lazyload.min.jsm. (Reason: CORS request not http). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.12.1/css/all.min.css. (Reason: CORS request did not succeed). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/jets/0.14.1/jets.min.js. (Reason: CORS request did not succeed). None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js. (Reason: CORS request did not succeed). None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.jsdelivr.net/npm/vanilla-lazyload@15.1.1/dist/lazyload.min.js. (Reason: CORS request did not succeed). None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/jquery/3.5.1/jquery.min.jsm. (Reason: CORS request not http). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdnjs.cloudflare.com/ajax/libs/jquery/3.5.1/jquery.min.js. (Reason: CORS request did not succeed). None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at moz-extension://a9e36a02-3e43-e84e-8377-414e25fb8da8/resources/vanilla-lazyload/17.3.0/lazyload.min.jsm. (Reason: CORS request not http). Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.jsdelivr.net/npm/vanilla-lazyload@15.1.1/dist/lazyload.min.js. (Reason: CORS request did not succeed). None of the "sha512" hashes in the integrity attribute match the content of the subresource. 2fa.directory Uncaught TypeError: Bootstrap's JavaScript requires jQuery. jQuery must be included before Bootstrap's JavaScript. jQueryDetection https://2fa.directory/js/bootstrap.min.js:5 <anonymous> https://2fa.directory/js/bootstrap.min.js:5 <anonymous> https://2fa.directory/js/bootstrap.min.js:5 <anonymous> https://2fa.directory/js/bootstrap.min.js:5 bootstrap.min.js:5:3633 Uncaught ReferenceError: jQuery is not defined <anonymous> https://2fa.directory/js/popup.js:1 popup.js:1:1 Uncaught ReferenceError: $ is not defined <anonymous> https://2fa.directory/js/main.js:1 main.js:1:1 Uncaught ReferenceError: $ is not defined <anonymous> https://2fa.directory/js/social-media.js:1 social-media.js:1:1 Uncaught ReferenceError: $ is not defined <anonymous> https://2fa.directory/js/search.js:1 search.js:1:1 <anonymous> https://2fa.directory/js/search.js:1 ``` Steps to reproduce: 1. Visit https://2fa.directory/ 2. Click on region dropdown and select a region. 3. once the region page loads, the region dropdown now locks
nobody added the
firefox-bug
label 7 months ago
Owner

I've just tested this with the same version of Firefox Beta. After changing the region, the drop-down menu no longer works. In the normal Firefox version, the drop-down field works after several changes.

Looks like a bug in Firefox Beta.

I've just tested this with the same version of Firefox Beta. After changing the region, the drop-down menu no longer works. In the normal Firefox version, the drop-down field works after several changes. Looks like a bug in Firefox Beta.
Owner

Feel free to reopen this issue if it still persists. I think the best thing on beta versions is to open a bug report at Mozilla.

Feel free to reopen this issue if it still persists. I think the best thing on beta versions is to open a bug report at Mozilla.
nobody closed this issue 7 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.