#254 messages.google.com broken

Closed
opened 3 months ago by Dustie · 1 comments
Dustie commented 3 months ago

Problem:
https://messages.google.com/ doesn't load completely / doesn't work as intended.

Browser:
Firefox 84.0.2 + Firefox 85.0

Testing utility result:
Result for »messages.google.com«
• No CSP header found
• No Service Worker found
• Crossorigin and/or integrity attributes found!

Console errors:
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

Console errors with Filter HTML source ON:

Uncaught (in promise) Error: Wc`Unable to load module: bugle. See http://pantheon/demo2/components/deferred-loader#unable-to-load-module.`CustomError: Error loading bugle: Consecutive load failures
    zy https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1861
    promise callback*_.zy https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1861
    d https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:3294
    Am https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:384
    next_ https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:383
    next https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:385
m=b:1861:250

Uncaught (in promise) 
Object { stack: "_.aa@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:7:360\nsya@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1847:276\nvya/<@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1849:324\npy.prototype.execute@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1841:94\nb@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1429:243\npya@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1844:325\nqy.prototype.un@https://www.gstatic.com/_/me…", message: "Error loading bootstrap: Consecutive load failures", ha: true }


**Problem**: https://messages.google.com/ doesn't load completely / doesn't work as intended. **Browser**: Firefox 84.0.2 + Firefox 85.0 **Testing utility result**: Result for »messages.google.com« • No CSP header found • No Service Worker found • Crossorigin and/or integrity attributes found! **Console errors**: `Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).` **Console errors with Filter HTML source ON**: ``` Uncaught (in promise) Error: Wc`Unable to load module: bugle. See http://pantheon/demo2/components/deferred-loader#unable-to-load-module.`CustomError: Error loading bugle: Consecutive load failures zy https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1861 promise callback*_.zy https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1861 d https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:3294 Am https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:384 next_ https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:383 next https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:385 m=b:1861:250 Uncaught (in promise) Object { stack: "_.aa@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:7:360\nsya@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1847:276\nvya/<@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1849:324\npy.prototype.execute@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1841:94\nb@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1429:243\npya@https://www.gstatic.com/_/messagesweb/_/js/k=messagesweb.mw.en_GB.4tdFlqIv8y0.O/am=-glgBA/d=1/ct=zgms/rs=AIp04d_oY5aSgJCGPeswFWjwpcsZJAq8Aw/m=b:1844:325\nqy.prototype.un@https://www.gstatic.com/_/me…", message: "Error loading bootstrap: Consecutive load failures", ha: true } ```
nobody commented 3 months ago
Owner

I don't get the identical error message, but looks like something is missing that should be loaded from www.gstatic.com. Unfortunately, www.gstatic.com is a CDN that LocalCDN listens to. (here)

You could

  • disable the extension for this website or
  • allow reloading of missing resources

I would disable the extension for this website, because CDN and website owner is identical (Google). You don't need to protect that with LocalCDN 😉

I don't get the identical error message, but looks like something is missing that should be loaded from www.gstatic.com. Unfortunately, www.gstatic.com is a CDN that LocalCDN listens to. ([here](https://codeberg.org/nobody/LocalCDN/src/branch/main/core/mappings.js#L941)) You could * disable the extension for this website **or** * allow reloading of missing resources I would disable the extension for this website, because CDN and website owner is identical (Google). You don't need to protect that with LocalCDN :wink:
nobody added the
wontfix
label 3 months ago
nobody closed this issue 3 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.