Invert HTML Filter option breaks sourcecode view and some other stuff #234

Closed
opened 9 months ago by hacktivista · 4 comments

When I set the Invert HTML Filter option the sourcecode view (Ctrl+u) breaks. (picture attached)

Also when I open a webpage with no sourcecode at all (probably with no tags?) it spends a whole lot of time to load.

When I set the `Invert HTML Filter` option the sourcecode view (`Ctrl+u`) breaks. (picture attached) Also when I open a webpage with no sourcecode at all (probably with no tags?) it spends a whole lot of time to load.
nobody added the
bug
label 9 months ago
nobody added this to the v2.6.0 milestone 9 months ago
Owner

Thank you for your report 👍

I was able to reproduce this. Looks like a Firefox bug. I' ve modified the behavior of the HTML filter and restrict it to HTTPS and HTTP URLs. If you want, feel free to test it.

https://codeberg.org/nobody/LocalCDN/wiki#5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that

Thank you for your report 👍 I was able to reproduce this. Looks like a Firefox bug. I' ve modified the behavior of the HTML filter and restrict it to HTTPS and HTTP URLs. If you want, feel free to test it. https://codeberg.org/nobody/LocalCDN/wiki#5-you-recently-changed-something-in-the-code-and-i-would-like-to-test-it-how-can-i-do-that
nobody referenced this issue from a commit 9 months ago
nobody added the
testing
label 9 months ago
Owner

A public beta version is available: https://codeberg.org/nobody/LocalCDN/releases/tag/v2.6.0beta2

A public beta version is available: https://codeberg.org/nobody/LocalCDN/releases/tag/v2.6.0beta4

~~A public beta version is available: `https://codeberg.org/nobody/LocalCDN/releases/tag/v2.6.0beta2`~~ A public beta version is available: https://codeberg.org/nobody/LocalCDN/releases/tag/v2.6.0beta4
Owner

Looks good. Could not find any errors.

If it doesn't work for you, feel free to reopen the issue.

Looks good. Could not find any errors. If it doesn't work for you, feel free to reopen the issue.
nobody removed the
testing
label 8 months ago
nobody closed this issue 8 months ago
Owner

I have rolled back the changes in LocalCDN. This is definitely a Firefox bug since v84.0.

I have created an issue about this: https://bugzilla.mozilla.org/show_bug.cgi?id=1688146

I have rolled back the changes in LocalCDN. This is definitely a Firefox bug since v84.0. I have created an issue about this: https://bugzilla.mozilla.org/show_bug.cgi?id=1688146
nobody added
wontfix
and removed
bug
labels 8 months ago
nobody removed this from the v2.6.0 milestone 8 months ago
nobody added the
firefox-bug
label 7 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.