#174 Restore and backup

Closed
opened 5 months ago by Redback813 · 5 comments

To whom this concerns

First, I like to thank the author of this wonderful program and helping users to protect their privacy. The issue is with restore and backup however "Restore" is the issue in itself, the problem exist in both Firefox (Version 82.0.2) and Brave (Version 1.16.76 Chromium: 86.0.4240.198 (Official Build) (x86_64)). When I do a backup in both said browsers there is no issue however when I do a restore in both browsers the restore function fails with "Import failed: whitelistedDomains" as images are shown from each browsers.

Cheers

To whom this concerns First, I like to thank the author of this wonderful program and helping users to protect their privacy. The issue is with restore and backup however "Restore" is the issue in itself, the problem exist in both Firefox (Version 82.0.2) and Brave (Version 1.16.76 Chromium: 86.0.4240.198 (Official Build) (x86_64)). When I do a backup in both said browsers there is no issue however when I do a restore in both browsers the restore function fails with "Import failed: whitelistedDomains" as images are shown from each browsers. Cheers

This problem should be fixed by 0a6d78e8c2, now we will have to wait for a new release to include this fix.

This problem should be fixed by https://codeberg.org/nobody/LocalCDN/commit/0a6d78e8c216eb7b23bc0f7c8a9390398c56b079, now we will have to wait for a new release to include this fix.
nobody commented 5 months ago
Owner

fyjzjj3yva is right that problem has been fixed and will be released with the next update. The problem is that validation fails because the whitelistedDomains entry has been renamed to allowlistedDomains.

You can also edit the file manually:

  • If allowlistedDomains exists:
    • maybe copy the entries allowlistedDomains
    • delete whitelistedDomains.
  • If allowlistedDomains doesn't exist:
    • rename whitelistedDomains to allowlistedDomains.

You can also send me the file and I'll edit it for you 😉

fyjzjj3yva is right that problem has been fixed and will be released with the next update. The problem is that validation fails because the `whitelistedDomains` entry has been renamed to `allowlistedDomains`. You can also edit the file manually: * If `allowlistedDomains` exists: * maybe copy the entries `allowlistedDomains` * delete `whitelistedDomains`. * If `allowlistedDomains` doesn't exist: * rename `whitelistedDomains` to `allowlistedDomains`. You can also send me the file and I'll edit it for you :wink:
Poster

Thank you ! The "allowlistedDomains" was in the backup file and also deleted the "whitelistedDomains" from the said backups as well and all the backups works like a treat.

Cheers

Thank you ! The "allowlistedDomains" was in the backup file and also deleted the "whitelistedDomains" from the said backups as well and all the backups works like a treat. Cheers
nobody commented 5 months ago
Owner

I'm very pleased to hear that 😊 👍

I'm very pleased to hear that :blush: 👍
nobody added the
question/discussion
label 5 months ago
nobody added the
bug
label 5 months ago
nobody closed this issue 5 months ago
nobody added this to the v2.5.7 milestone 5 months ago
nobody commented 5 months ago
Owner

(see #138)

(see #138)
nobody referenced this issue from a commit 5 months ago
nobody modified the milestone from v2.5.7 to v2.5.11 5 months ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.