Version selection: LocalCDN downgrades frameworks #165

Closed
opened 10 months ago by fyjzjj3yva · 4 comments

A website I am visiting requests plyr 3.6.2, which is the latest release of plyr. LocalCDN only has the older version, 3.5.10, so it downgrades plyr:
[ LocalCDN ] Replaced resource: resources/plyr/3.5.10/plyr.min.css

This is good for privacy (and bandwidth), but we cannot benefit from potential bug fixes and improvements in new versions.

Ideas:

  • Option to disable downgrading?
  • Log to console when a newer version is requested by website?
  • Subscribe to (GitHub, GitLab...) RSS feeds of all frameworks to receive updates when a new version is released?

By the way:
Missing resource: cdnjs.cloudflare.com/ajax/libs/plyr/3.6.2/plyr.min.js
and the following non-JS/CSS resources are also requested by the plyr framework:

https://cdn.plyr.io/3.6.2/plyr.svg
https://cdn.plyr.io/static/blank.mp4
A website I am visiting requests [plyr](https://github.com/sampotts/plyr) 3.6.2, which is the latest release of plyr. LocalCDN only has the older version, 3.5.10, so it downgrades plyr: `[ LocalCDN ] Replaced resource: resources/plyr/3.5.10/plyr.min.css` This is good for privacy (and bandwidth), but we cannot benefit from potential bug fixes and improvements in new versions. Ideas: * Option to disable downgrading? * Log to console when a newer version is requested by website? * Subscribe to (GitHub, GitLab...) RSS feeds of all frameworks to receive updates when a new version is released? ----- By the way: `Missing resource: cdnjs.cloudflare.com/ajax/libs/plyr/3.6.2/plyr.min.js` and the following non-JS/CSS resources are also requested by the plyr framework: ``` https://cdn.plyr.io/3.6.2/plyr.svg https://cdn.plyr.io/static/blank.mp4 ```
nobody added the
missing framework/mapping
label 10 months ago
nobody added this to the v2.5.7 milestone 10 months ago
Owner

Thanks for your report. Normally a downgrade isn't intended, only an upgrade. But this happens when the website is new or has been rebuilt. It is very rare that a website updates a framework. I have never noticed anything like this before. Usually the website is created with certain versions and stays that way.

Subscribe to (GitHub, GitLab...) RSS feeds of all frameworks to receive updates when a new version is released?

I already have a subscription to many frameworks, so I update them by myself. Unfortunately Plyr was not included.

https://cdn.plyr.io/3.6.2/plyr.svg
https://cdn.plyr.io/static/blank.mp4

I think these two can be ignored. The SVG file is empty for me anyway.

cdnjs.cloudflare.com/ajax/libs/plyr/3.6.2/plyr.min.js

Hmm, I'm just wondering why I didn't include the JavaScript file in v3.5.10 🤔 Now it is integrated.

Thanks for your report. Normally a downgrade isn't intended, only an upgrade. But this happens when the website is new or has been rebuilt. It is very rare that a website updates a framework. I have never noticed anything like this before. Usually the website is created with certain versions and stays that way. > Subscribe to (GitHub, GitLab...) RSS feeds of all frameworks to receive updates when a new version is released? I already have a subscription to many frameworks, so I update them by myself. Unfortunately Plyr was not included. > `https://cdn.plyr.io/3.6.2/plyr.svg` > `https://cdn.plyr.io/static/blank.mp4` I think these two can be ignored. The SVG file is empty for me anyway. > `cdnjs.cloudflare.com/ajax/libs/plyr/3.6.2/plyr.min.js` Hmm, I'm just wondering why I didn't include the JavaScript file in v3.5.10 🤔 Now it is integrated.
Poster

The SVG cannot be ignored because it is an SVG sprite.

Example test URL (base64):
aHR0cHM6Ly9hbmltaXhwbGF5LnRvL3YxL3RvbmlrYWt1LWthd2FpaS9lcDY=

If you block the SVG, clear the browser cache and reload the page, you will find that the icons used in the Plyr controls will be missing. Revealing the SVG's source by a text editor also proves that the SVG is not empty.

The blank.mp4, according to Plyr's readme, is "a blank video file used to properly cancel network requests". I am not sure what this means though.

The SVG cannot be ignored because it is an [SVG sprite](https://css-tricks.com/svg-sprites-use-better-icon-fonts/). Example test URL (base64): `aHR0cHM6Ly9hbmltaXhwbGF5LnRvL3YxL3RvbmlrYWt1LWthd2FpaS9lcDY=` If you block the SVG, clear the browser cache and reload the page, you will find that the icons used in the Plyr controls will be missing. Revealing the SVG's source by a text editor also proves that the SVG is not empty. The `blank.mp4`, according to Plyr's readme, is "a blank video file used to properly cancel network requests". I am not sure what this means though.
nobody referenced this issue from a commit 10 months ago
Owner

In my case the icons are loaded correctly, while the connection is blocked and the cache is disabled. I added this anyway.

In my case the icons are loaded correctly, while the connection is blocked and the cache is disabled. I added this anyway.
Poster

I can always reproduce by:

  1. Fresh browser profile
  2. ||https://cdn.plyr.io/3.6.2/plyr.svg in uBlock Origin
  3. Load the webpage and icons are not loaded (screenshot)

Anyway, thanks for the fix!

I can always reproduce by: 1. Fresh browser profile 2. `||https://cdn.plyr.io/3.6.2/plyr.svg` in uBlock Origin 3. Load the webpage and icons are not loaded (screenshot) Anyway, thanks for the fix!
fyjzjj3yva closed this issue 10 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.