#136 Firefox for Android v79+ (Fenix) support

Closed
opened 6 months ago by maxigaz · 6 comments
maxigaz commented 6 months ago

Are there any plans to port LocalCDN to Firefox for Android v79+ (Fenix)?

The recent updates of Fennec F-Droid are now based on Fenix, where LocalCDN is marked as incompatible on AMO and in the list of installed extensions, and is thus disabled. On the other hand, Decentraleyes works fine.

Are there any plans to port LocalCDN to Firefox for Android v79+ (Fenix)? The recent updates of Fennec F-Droid are now based on Fenix, where LocalCDN is marked as incompatible on AMO and in the list of installed extensions, and is thus disabled. On the other hand, Decentraleyes works fine.

Try using beta or nightly, I'm pretty sure you can set set it to install any extension.

Try using beta or nightly, I'm pretty sure you can set set it to install any extension.
maxigaz commented 6 months ago
Poster

Do you mean one of the packages here, for example?

Do you mean one of the packages [here](https://github.com/mozilla-mobile/fenix/releases), for example?
nobody added the
question/discussion
label 6 months ago
nobody commented 6 months ago
Owner

There are no plans, because it already works 😉

This is unfortunately caused by Mozilla. They choose which extensions are locked and which are not. Currently only 9 of all 98 recommended extensions can be installed. This is annoying and makes me angry because I don't understand this decision 😒

It's possible with Nightly and Collections. Yesterday I restructured the wiki a little bit: Can I use LocalCDN in Firefox for Android (Fenix)?

There are no plans, because it already works :wink: This is unfortunately caused by Mozilla. They choose which extensions are locked and which are not. Currently only 9 of all 98 recommended extensions can be installed. This is annoying and makes me angry because I don't understand this decision :unamused: It's possible with Nightly and Collections. Yesterday I restructured the wiki a little bit: [Can I use LocalCDN in Firefox for Android (Fenix)?](https://codeberg.org/nobody/LocalCDN/wiki#user-content-13-can-i-use-localcdn-in-firefox-for-android-fenix)
maxigaz commented 6 months ago
Poster

There are no plans, because it already works 😉

This is unfortunately caused by Mozilla. They choose which extensions are locked and which are not. Currently only 9 of all 98 recommended extensions can be installed. This is annoying and makes me angry because I don't understand this decision 😒

It's possible with Nightly and Collections. Yesterday I restructured the wiki a little bit: Can I use LocalCDN in Firefox for Android (Fenix)?

Oh, I see. I’m sorry to hear that. Let’s hope Mozilla will unlock it soon. (In the meantime, I’ll keep using LocalCDN on the desktop.) Thank you for your reply and your work!

> There are no plans, because it already works :wink: > > This is unfortunately caused by Mozilla. They choose which extensions are locked and which are not. Currently only 9 of all 98 recommended extensions can be installed. This is annoying and makes me angry because I don't understand this decision :unamused: > > It's possible with Nightly and Collections. Yesterday I restructured the wiki a little bit: [Can I use LocalCDN in Firefox for Android (Fenix)?](https://codeberg.org/nobody/LocalCDN/wiki#user-content-13-can-i-use-localcdn-in-firefox-for-android-fenix) > > > > Oh, I see. I’m sorry to hear that. Let’s hope Mozilla will unlock it soon. (In the meantime, I’ll keep using LocalCDN on the desktop.) Thank you for your reply and your work!
maxigaz closed this issue 6 months ago
nobody commented 6 months ago
Owner

Thanks for your understanding. I hope with every Firefox update that more extensions are unlocked, but unfortunately I was disappointed every time.

Currently I'm using Nightly as normal browser on Android. Works stable so far. But I've activated the crash report there, because it's still in development.

Thanks for your understanding. I hope with every Firefox update that more extensions are unlocked, but unfortunately I was disappointed every time. Currently I'm using Nightly as normal browser on Android. Works stable so far. But I've activated the crash report there, because it's still in development.
nobody added the
observation
label 5 months ago
nobody commented 2 months ago
Owner

Short update: The workaround via the collection is also possible for Fennec from F-Droid. Advantage: Fennec is not a beta version 😉

I do not know with which update this was activated. I just read this by chance and wanted to keep you updated. I think we don't have to wait much longer to see all extensions unlocked.

Short update: The workaround via the collection is also possible for [Fennec from F-Droid](https://f-droid.org/en/packages/org.mozilla.fennec_fdroid/). Advantage: Fennec is not a beta version :wink: I do not know with which update this was activated. I just read this by chance and wanted to keep you updated. I think we don't have to wait much longer to see all extensions unlocked.
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.