Computeruniverse.de broken #117

Closed
opened 1 year ago by AndyRTR · 4 comments
AndyRTR commented 1 year ago

Please check e.g. https://www.computeruniverse.net/de/search?query=Google%20pixel%205

It only shows Cloudflare CDN / Rocket Loader and fails to render some parts. Disabling LocalCDN makes it load properly, version is 2.4.0 here.

Please check e.g. https://www.computeruniverse.net/de/search?query=Google%20pixel%205 It only shows Cloudflare CDN / Rocket Loader and fails to render some parts. Disabling LocalCDN makes it load properly, version is 2.4.0 here.

@AndyRTR, what settings are you using? Is LocalCDN your only addon? I'm asking because I just tried loading that site and nothing seems to be different when I toggle LocalCDN. Maybe you can upload some screenshots to illustrate the difference.

@AndyRTR, what settings are you using? Is LocalCDN your only addon? I'm asking because I just tried loading that site and nothing seems to be different when I toggle LocalCDN. Maybe you can upload some screenshots to illustrate the difference.
Poster

Screenshot attached. The fonts in the centre part aren't rendered here. This gets fixed here when disabling LocalCDN.

Yes, there's also running µblock Origin (tried to disable with no difference, 3rd party JS needs to be enabled here) and a few more (Smart Referer, Skip Redirect, RSSPreview, NeatURL, Leo Dictionaries, KeepassXC-Browser, First Party Isolation).

Screenshot attached. The fonts in the centre part aren't rendered here. This gets fixed here when disabling LocalCDN. Yes, there's also running µblock Origin (tried to disable with no difference, 3rd party JS needs to be enabled here) and a few more (Smart Referer, Skip Redirect, RSSPreview, NeatURL, Leo Dictionaries, KeepassXC-Browser, First Party Isolation).

Can you please try in a new browser profile only with LocalCDN? I have uBlock Origin, uMatrix (which I turned off for my test), Skip Redirect, FPI, RFP, and a bunch of other extensions, but LocalCDN doesn't break the site for me. It could be that due to your settings, LocalCDN is interacting with some other extension which is why it's breaking for you.

Can you please try in a new browser profile _only_ with LocalCDN? I have uBlock Origin, uMatrix (which I turned off for my test), Skip Redirect, FPI, RFP, and a bunch of other extensions, but LocalCDN doesn't break the site for me. It could be that due to your settings, LocalCDN is interacting with some other extension which is why it's breaking for you.
nobody added the
missing framework/mapping
label 1 year ago
Owner

@AndyRTR: Thanks for your report! I can confirm this. I have added the frameworks. But then you have to activate the HTML filter, because the frameworks are protected in the HTML source code with crossorigin/integrity.


@chiraag-nataraj: You have to enable the options

(Thanks for translating 😉 👍)

@AndyRTR: Thanks for your report! I can confirm this. I have added the frameworks. But then you have to activate the HTML filter, because the frameworks are protected in the HTML source code with crossorigin/integrity. --- @chiraag-nataraj: You have to enable the options * *Block requests for missing resources* and * *Enable logging in browser console* [(Wiki - How to logging)](https://codeberg.org/nobody/LocalCDN/wiki/How-to-logging) (Thanks for translating :wink: 👍)
nobody closed this issue 1 year ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.