An experiment in building a better XMPP client. This time using Flutter.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
moxxyv2/pubspec.yaml

140 lines
3.6 KiB

name: moxxyv2
description: An experimental XMPP client
publish_to: 'none'
version: 0.2.3+4
environment:
sdk: ">=2.16.1 <3.0.0"
flutter: ">=2.13.0-0.1"
dependencies:
archive: 3.3.1
badges: 2.0.3
better_open_file: 3.6.3
bloc: 8.1.0
connectivity_plus: 2.3.6
crop_your_image: 0.7.2
cryptography: 2.0.5
#cupertino_icons: 1.0.2
dart_emoji: 0.2.0+2
decorated_icon: 1.2.1
dio: 4.0.6
emoji_picker_flutter: 1.3.1
equatable: 2.0.3
external_path: 1.0.1
file_picker: 5.0.1
flutter:
sdk: flutter
flutter_bloc: 8.1.1
flutter_blurhash: 0.7.0
flutter_image_compress: 1.1.0
flutter_isolate: 2.0.2
flutter_local_notifications: 9.7.0
flutter_parsed_text: 2.2.1
flutter_secure_storage: 5.0.2
flutter_speed_dial: 6.0.0
flutter_vibrate: 1.3.0
freezed_annotation: 2.1.0
get_it: 7.2.0
hex: 0.2.0
image: 3.2.0
image_size_getter: 2.1.2
json_annotation: 4.6.0
logging: 1.0.2
mime: 1.0.2
move_to_background:
git:
url: https://github.com/ViliusP/move_to_background.git
ref: e5cc2eefd1667e8ef22f21f41b0ef012b060be6c
moxdns:
hosted: https://git.polynom.me/api/packages/Moxxy/pub
version: 0.1.4
moxlib:
hosted: https://git.polynom.me/api/packages/Moxxy/pub
version: 0.1.4
moxplatform:
hosted: https://git.polynom.me/api/packages/Moxxy/pub
version: 0.1.11+2
moxxyv2_builders:
hosted: https://git.polynom.me/api/packages/Moxxy/pub
version: 0.1.0
native_imaging: 0.1.0
page_transition: 2.0.9
path: 1.8.1
path_provider: 2.0.11
permission_handler: 10.0.0
phosphor_flutter: 1.4.0
#qr_code_scanner: 0.6.1
qr_flutter: 4.0.0
random_string: 2.3.1
saslprep: 1.0.2
settings_ui: 2.0.2
share_handler: 0.0.16
sqflite_sqlcipher: 2.1.1
#scrollable_positioned_list: 0.2.3
stack_blur: 0.2.2
swipeable_tile:
git:
url: https://github.com/PapaTutuWawa/swipeable_tile.git
ref: bfab5e28f1f1ea624232002f0d05481cb2bd9997
synchronized: 3.0.0
udp: 5.0.3
url_launcher: 6.1.5
#unifiedpush: 3.0.1
uuid: 3.0.5
video_thumbnail:
git: https://github.com/ajbcoder/video_thumbnail
#video_thumbnail: ^0.5.2
xml: ^6.1.0
dev_dependencies:
build_runner: ^2.1.11
flutter_launcher_icons: ^0.9.3
flutter_lints: ^2.0.1
#flutter_test:
# sdk: flutter
freezed: ^2.1.0+1
json_serializable: ^6.3.1
meta: ^1.7.0
test: ^1.21.1
very_good_analysis: ^3.0.1
dependency_overrides:
# Okay, so hear me out: Flutter has the problem that focusing a TextField will automatically
# summon the soft keyboard with no way of (dynamically) telling it to not do that. This
# causes the issue in the ConversationPage where changing the cursor's position within the
# TextField while the Emoji picker is open summons the soft keyboard, having it stacked
# under the Emoji picker.
#
# My fork adds a callback function that is called whenever the soft keyboard is about to be
# summoned, with which we can tell flutter whether it should summon it or not.
flutter:
hosted: https://git.polynom.me/api/packages/Moxxy/pub
version: 3.0.1
extra_licenses:
- name: undraw.co
license: "custom license"
url: "https://undraw.co"
- name: xmpp-providers
# TODO: Dangerous
license: "unknown license"
url: "https://invent.kde.org/melvo/xmpp-providers"
flutter:
uses-material-design: true
assets:
- assets/images/logo.png
- assets/images/begin_chat.png
- assets/images/happy_news.png
flutter_icons:
android: true
ios: "assets/images/icon_ios.png"
remove_alpha_ios: true
# TODO: This maybe not good
image_path: "assets/images/logo.png"
adaptive_icon_background: "#8315d2"
adaptive_icon_foreground: "assets/images/icon_android_adaptive.png"