45 lines
1.1 KiB
Nix
45 lines
1.1 KiB
Nix
{
|
|
description = "configuration for my nix systems";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "nixpkgs/nixpkgs-unstable";
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager/master";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
simple-nixos-mailserver = {
|
|
url = "gitlab:simple-nixos-mailserver/nixos-mailserver/master";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
prismlauncher.url = "github:PrismLauncher/PrismLauncher";
|
|
emacs-overlay = {
|
|
url = "github:nix-community/emacs-overlay";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
outputs = { nixpkgs, home-manager, ... }@inputs:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = import nixpkgs {
|
|
inherit system;
|
|
config.allowUnfree = true;
|
|
};
|
|
|
|
lib = nixpkgs.lib;
|
|
in {
|
|
nixosConfigurations = {
|
|
azeban = lib.nixosSystem {
|
|
inherit system;
|
|
specialArgs = { inherit inputs; };
|
|
modules = [ ./azeban ];
|
|
};
|
|
ceasg = lib.nixosSystem {
|
|
inherit system;
|
|
specialArgs = { inherit inputs; };
|
|
modules = [ ./ceasg ];
|
|
};
|
|
};
|
|
};
|
|
}
|