Feature request #577

Open
opened 2 months ago by Cloud87650 · 0 comments

General information

  • Version: 3.0.7
  • Device: OnePlus 7 Pro
  • Android Version: Android 11
  • Server name: blabber.im, conversations.im, jabber.de or self hosted
  • Server software: ejabberd 19.09.1 or prosody 0.11.3 (if known)
  • Installed server modules: Stream Managment, CSI, MAM
  • Pix-Art Messenger source: PlayStore, PlayStore Beta Channel, F-Droid, Github, Codeberg, self build (latest HEAD)

Steps to reproduce

  1. If you turn on the TOR option without ORBot, you get disconnected until you disable the setting

Expected result

What is the expected output?

I think someone should add text to it such as:
"orbot installation required"

That or you could add a pop up that tells you to disable or download ORBot to reconnect

Actual result

What do you see instead?

You get disconnected from the servers and no warning pops up explaining why

Debug output

Please post the output of adb logcat. The log should begin with the start of blabber.im and include all the
steps it takes to reproduce the problem.

Linux: adb -d logcat -v time | grep -i blabber.im > logcat.txt
Windows: adb -d logcat -v time | FINDSTR blabber.im > logcat.txt
#### General information * **Version:** 3.0.7 * **Device:** OnePlus 7 Pro * **Android Version:** Android 11 * **Server name:** blabber.im, conversations.im, jabber.de or self hosted * **Server software:** ejabberd 19.09.1 or prosody 0.11.3 (if known) * **Installed server modules:** Stream Managment, CSI, MAM * **Pix-Art Messenger source:** PlayStore, PlayStore Beta Channel, F-Droid, Github, Codeberg, self build (latest HEAD) #### Steps to reproduce 1. If you turn on the TOR option without ORBot, you get disconnected until you disable the setting #### Expected result What is the expected output? I think someone should add text to it such as: "orbot installation required" That or you could add a pop up that tells you to disable or download ORBot to reconnect #### Actual result What do you see instead? You get disconnected from the servers and no warning pops up explaining why #### Debug output Please post the output of adb logcat. The log should begin with the start of blabber.im and include all the steps it takes to reproduce the problem. ```` Linux: adb -d logcat -v time | grep -i blabber.im > logcat.txt Windows: adb -d logcat -v time | FINDSTR blabber.im > logcat.txt ````
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.