Replacing YT links with Invidious a bit buggy #553

Closed
opened 7 months ago by PeaceOfBread · 6 comments

General information

  • Version: 3.0.4 (and older versions too)
  • Device: Xiaomi Mi Mix 2S
  • Android Version: Android 10 (stock)
  • Server name: wiuwiu.de
  • Server software: Prosody 0.11.7 on Linux
  • Installed server modules: ???
  • Pix-Art Messenger source: F-Droid

Steps to reproduce

  1. Write a message with a Youtube link and write something behind it in the same line.
  2. Enable the setting that replaces Youtube links with Invidious links, and send the message.

Expected result

"invidiousinstance.com/?v=blabla&local=true I really like this!"

Actual result

"invidiousinstance.com/?v=blabla I really like this!&local=true"
The &local=true is be appended at the end of the line and not at the end of the link, as it is supposed to. This happens with my own as well as with other peoples messages (visually only, of course, the setting doesn’t change the sent message)

Debug output

no idea

Please don’t solve this issue by removing the &local=true from the links! That would be a privacy loss.

#### General information * **Version:** 3.0.4 (and older versions too) * **Device:** Xiaomi Mi Mix 2S * **Android Version:** Android 10 (stock) * **Server name:** wiuwiu.de * **Server software:** Prosody 0.11.7 on Linux * **Installed server modules:** ??? * **Pix-Art Messenger source:** F-Droid #### Steps to reproduce 1. Write a message with a Youtube link and write something behind it in the same line. 2. Enable the setting that replaces Youtube links with Invidious links, and send the message. #### Expected result "invidiousinstance.com/?v=blabla&local=true I really like this!" #### Actual result "invidiousinstance.com/?v=blabla I really like this!&local=true" The &local=true is be appended at the end of the line and not at the end of the link, as it is supposed to. This happens with my own as well as with other peoples messages (visually only, of course, the setting doesn’t change the sent message) #### Debug output no idea Please don’t solve this issue by removing the &local=true from the links! That would be a privacy loss.
Collaborator

Hi @PeaceOfBread

may you use the issue template?

Hi @PeaceOfBread may you use the issue template?
Echolon added the
Enhancement
label 7 months ago
Echolon added the
Low priority
Help wanted
labels 7 months ago
Poster

@Echolon

Hi @PeaceOfBread

may you use the issue template?

Why should I? I think the issue is very clear. And on my phone Gitea client there are none of the templates visible, sadly.

@Echolon >Hi @PeaceOfBread > >may you use the issue template? Why should I? I think the issue is very clear. And on my phone Gitea client there are none of the templates visible, sadly.
Poster

Hi @PeaceOfBread

may you use the issue template?

Ok, sorry, I’d do it. But I don’t know how to add the issue template after having made the issue already. I took it from a new one now.

> Hi @PeaceOfBread > > may you use the issue template? Ok, sorry, I’d do it. But I don’t know how to add the issue template after having made the issue already. I took it from a new one now.
kriztan closed this issue 6 months ago
PeaceOfBread reopened this issue 6 months ago

I seem not to have this issue after changing the invidious instance in the monocles fork to https://monocles.live . Maybe it's because invidious instances are quickly overloaded.

I seem not to have this issue after changing the invidious instance in the monocles fork to https://monocles.live . Maybe it's because invidious instances are quickly overloaded.
Poster

@Arne

I seem not to have this issue after changing the invidious instance in the monocles fork to https://monocles.live . Maybe it's because invidious instances are quickly overloaded.

Uhm, what? It doesn't have anything to do woth the site itself at all. It all works offline, just changing the link visually to what you put into settings. I'm very sure it doesn't connect to the site. But maybe the composition of the link does something.
And what monocles fork? A fork of blabber.im? Or you meant the Invidious instance?

@Arne >I seem not to have this issue after changing the invidious instance in the monocles fork to https://monocles.live . Maybe it's because invidious instances are quickly overloaded. Uhm, what? It doesn't have anything to do woth the site itself at all. It all works offline, just changing the link visually to what you put into settings. I'm very sure it doesn't connect to the site. But maybe the composition of the link does something. And what monocles fork? A fork of blabber.im? Or you meant the Invidious instance?
kriztan added this to the 3.1.0 milestone 4 weeks ago
Owner

should be fixed with 693c85cac5

should be fixed with https://codeberg.org/kriztan/blabber.im/commit/693c85cac5fe35c7e01c3d75d63fa7bb18f87d00
kriztan closed this issue 4 days ago
Sign in to join this conversation.
No Milestone
No Assignees
4 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.