bug(extension): GNOME 3.32 support #44

Closed
by protopopov1122 opened 3 years ago · 0 comments
protopopov1122 commented 3 years ago (Migrated from github.com)
Owner

Describe the bug
Extension does not work with GNOME Shell 3.32. In the log appears following line:

Mar 16 11:19:36 ArchNotebook gnome-shell[19525]: Extension "night-light-slider.timur@linux.com" had error: TypeError: this._construct is not a function

Most probably the issue is connected with recent GNOME Shell changes which break Lang.Class in favor of ES6 classes.
bacfdbbb03

System Information:

  • OS: Arch Linux (last updated on Mar 16)
  • GNOME Version: 3.32.0
**Describe the bug** Extension does not work with GNOME Shell 3.32. In the log appears following line: ``` Mar 16 11:19:36 ArchNotebook gnome-shell[19525]: Extension "night-light-slider.timur@linux.com" had error: TypeError: this._construct is not a function ``` Most probably the issue is connected with recent GNOME Shell changes which break `Lang.Class` in favor of ES6 classes. https://gitlab.gnome.org/GNOME/gnome-shell/commit/bacfdbbb0338b94295c64093523bca7ba8d5c5ca **System Information:** - OS: Arch Linux (last updated on Mar 16) - GNOME Version: 3.32.0
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.