Provider list autocreation #8

Closed
opened 8 months ago by poVoq · 8 comments
poVoq commented 8 months ago

A curated server list is probably a good idea, but they tend to get outdated really fast and/or become controversial due to their ususally very oppinionate nature.

A totally random autocreated like (Example: https://xmpp-servers.404.city/ ) however is probably also not a great idea.

Someone suggested this: https://invent.kde.org/melvo/xmpp-providers

As an example of an auto created list based on some criteria. However it is specificaly created for the Kaidan client I think, so it would need to be modified a bit.

This seems like the best idea and if people complain about the recommendations we can always point them to the source code and ask them to contribute to improve the selection criteria.

A curated server list is probably a good idea, but they tend to get outdated really fast and/or become controversial due to their ususally very oppinionate nature. A totally random autocreated like (Example: https://xmpp-servers.404.city/ ) however is probably also not a great idea. Someone suggested this: https://invent.kde.org/melvo/xmpp-providers As an example of an auto created list based on some criteria. However it is specificaly created for the Kaidan client I think, so it would need to be modified a bit. This seems like the best idea and if people complain about the recommendations we can always point them to the source code and ask them to contribute to improve the selection criteria.
Poster
Another curated list: https://list.jabber.at/ Edit: made with: https://github.com/mathiasertl/django-xmpp-server-list Edit: https://novaburst.tilde.team/services/xmpp-servers.html

The Kaidan list can be used too, as long as the list has some good choices to get the users started. For example the current choice in web page is jabber.fr which is in French and would be difficult for anyone not knowing French to onboard (no offence)

The Kaidan list can be used too, as long as the list has some good choices to get the users started. For example the current choice in web page is jabber.fr which is in French and would be difficult for anyone not knowing French to onboard (no offence)
Poster

The Django project to create the serverlist of jabber.at seems interesting:
https://github.com/mathiasertl/django-xmpp-server-list

The interesting part is that any server admin can easily add their server and there is also an API.

The Django project to create the serverlist of jabber.at seems interesting: https://github.com/mathiasertl/django-xmpp-server-list The interesting part is that any server admin can easily add their server and there is also an API.

become controversial due to their ususally very oppinionate nature.

For me, that's a feature, not a bug. The most important points (privacy policy, user experience, sustainability) cannot be measured by a machine. If we're not doing manual curation, then our list is as useless to newcomers as every other (long & confusing) list out there.

However, having machine-readable criteria to ensure our manually-curated list respects (and keeps respecting) a certain number of properties over time, could be really useful.

What do other people think?

> become controversial due to their ususally very oppinionate nature. For me, that's a feature, not a bug. The most important points (privacy policy, user experience, sustainability) cannot be measured by a machine. If we're not doing manual curation, then our list is as useless to newcomers as every other (long & confusing) list out there. However, having machine-readable criteria to ensure our manually-curated list respects (and keeps respecting) a certain number of properties over time, could be really useful. What do other people think?
Poster

Yes and no. I think the most important thing is that the (opinionated) criteria are fully transparent and that the list is open to additions without prejeduce.

Fullfilling these two IMHO essential factors is much easier if we have a list / API that is autocreated from a database that allows server admins to add their servers themselves.

So how could we get started on this? I think the Jabber.at system would be a really good starting point, even if we only use it as a secondary page to direct XMPP server admins to. As it offers a simple API, we can pull an oppinionated recommendation-list from it during building of the main website.

Yes and no. I think the most important thing is that the (opinionated) criteria are fully transparent and that the list is open to additions without prejeduce. Fullfilling these two IMHO essential factors is much easier if we have a list / API that is autocreated from a database that allows server admins to add their servers themselves. So how could we get started on this? I think the Jabber.at system would be a really good starting point, even if we only use it as a secondary page to direct XMPP server admins to. As it offers a simple API, we can pull an oppinionated recommendation-list from it during building of the main website.
Poster

I really don't have much clue about ansible, but maybe this would help to deploy the jabber.at list system on your server?
https://github.com/mrichnu/ansible-django

I really don't have much clue about ansible, but maybe this would help to deploy the jabber.at list system on your server? https://github.com/mrichnu/ansible-django
Poster
https://github.com/thekinrar/mastodon-instances wizard/listing based on the json file from here: https://invent.kde.org/melvo/xmpp-providers ?

So far we've prefered manual curation over automatic curation. Patches for an automated list are still welcome, whether to link to one or to setup one on our infra. In the meantime, i'll be closing this issue since it seems nobody wants to take care of it.

Feel free to revive it anytime!

So far we've prefered manual curation over automatic curation. Patches for an automated list are still welcome, whether to link to one or to setup one on our infra. In the meantime, i'll be closing this issue since it seems nobody wants to take care of it. Feel free to revive it anytime!
southerntofu closed this issue 3 months ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.