Misleading Gitea update message #978

Closed
opened 4 weeks ago by -keks- · 3 comments
-keks- commented 4 weeks ago

# What do you want to address?

  • Bug
  • Feature
  • Suggestion

# Describe your matter briefly

I just freshly installed GitNex 4.0.0 via F-Droid. But when I try to connect to my Gitea instance I receive a confusing message in a yellow box.

In English the message would roughly be:

New Gitea version detected. Please update GitNex.

I just installed the latest GitNex version and it asks me to update? How should this be possible?

What did you expect?

GitNex should not show me a message regarding updating when I'm running the latest version already.

Some additional details

  • The version of Gitea you are using: 1.15.2-p0 from Debian repo
  • The version of GitNex you are using: 4.0.0
  • Source of installation (Play Store, F-Droid, APK): F-Droid
  • Current android version and phone model/manufacturer: Samsung S7, Android 8.0.0
  • The type of certificate your instance is using (self-signed, signed): self-signed
  • How you used to log in (via password or token): password
We would appreciate some screenshots or stacktrace's, but this is also not required.

See attached login01.jpg for the update message.

Thank you for your time.

## # What do you want to address? - [ ] Bug - [ ] Feature - [x] Suggestion ## # Describe your matter briefly I just freshly installed GitNex 4.0.0 via F-Droid. But when I try to connect to my Gitea instance I receive a confusing message in a yellow box. In English the message would roughly be: > New Gitea version detected. Please update GitNex. I just installed the latest GitNex version and it asks me to update? How should this be possible? ##### What did you expect? GitNex should not show me a message regarding updating when I'm running the latest version already. ##### Some additional details --- * The version of **Gitea** you are using: 1.15.2-p0 from Debian repo * The version of **GitNex** you are using: 4.0.0 * Source of installation (Play Store, F-Droid, APK): F-Droid * Current android version and phone model/manufacturer: Samsung S7, Android 8.0.0 * The type of certificate your instance is using (self-signed, signed): self-signed * How you used to log in (via password or token): password ##### We would appreciate some screenshots or stacktrace's, but this is also not required. --- See attached login01.jpg for the update message. #### Thank you for your time.
Collaborator

gitea is on debian now ?!?

gitea is on debian now ?!?
Collaborator

anyway ... gitnex do work as intended ... https://codeberg.org/gitnex/GitNex/src/tag/4.0.0/app/src/main/res/values/gitea_version.xml

It will check if gitnex is to old for a specific gitea version (since this could result in unexpected behaviour)

with next version it should not show that (https://codeberg.org/gitnex/GitNex/src/tag/main/app/src/main/res/values/gitea_version.xml)

anyway ... gitnex do work as intended ... https://codeberg.org/gitnex/GitNex/src/tag/4.0.0/app/src/main/res/values/gitea_version.xml It will check if gitnex is to old for a specific gitea version (since this could result in unexpected behaviour) with next version it should not show that (https://codeberg.org/gitnex/GitNex/src/tag/main/app/src/main/res/values/gitea_version.xml)
6543 added the
Brainstorming
label 4 weeks ago
Poster

gitea is on debian now ?!?

Uh, you're right. My bad.

Repo source is https://packaging.gitlab.io/gitea

> gitea is on debian now ?!? Uh, you're right. My bad. Repo source is https://packaging.gitlab.io/gitea
mmarif added this to the 4.1.0 milestone 4 weeks ago
mmarif added
Major-release
and removed
Brainstorming
labels 4 weeks ago
mmarif added
Major-release
and removed
Major-release
labels 3 weeks ago
mmarif referenced this issue from a commit 1 week ago
mmarif closed this issue 1 week ago
Sign in to join this conversation.
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.