[Pull] Optimize fragments, add filters, fix search and clean up #439

Closed
opened 2 years ago by mmarif · 16 comments
mmarif commented 2 years ago
Owner

A rough PR which fixed few things along the way and added filter for pr and issues(need to redo).

PR filter should work flawlessly and need you guys opinoin on it. If it's fine I can proceed with further fixes and enhacements.

Waiting for your feedback on this.

Closes #414 #385

Ref issue #278

Edit: I will update this post to add the related issues to be closed/addressed OR please add if you see one.


Original Pull att :https://gitea.com/gitnex/GitNex/pulls/439

Merged with: 0ee5b43996

A rough PR which fixed few things along the way and added filter for pr and issues(need to redo). PR filter should work flawlessly and need you guys opinoin on it. If it's fine I can proceed with further fixes and enhacements. Waiting for your feedback on this. Closes #414 #385 Ref issue #278 **Edit: I will update this post to add the related issues to be closed/addressed OR please add if you see one.** --- Original Pull att :https://gitea.com/gitnex/GitNex/pulls/439 Merged with: 0ee5b43996e24bd8f4231164e85963f6534819b8
mmarif added this to the 3.0.0 milestone 2 years ago
mmarif added the
Enhancement
Feature
Refactor
UI/UX
labels 2 years ago
mmarif closed this issue 2 years ago
mmarif was assigned by 6543 2 years ago
Collaborator

There are multiple progress bars when issues are being loaded.

There are multiple progress bars when issues are being loaded.
Collaborator

This is not a big problem, but in issues the list is empty while the progress bar spins. The opposite is true when pull requests are loading.

This is not a big problem, but in issues the list is empty while the progress bar spins. The opposite is true when pull requests are loading.
Collaborator

It would be nice too, if we would have some kind of indication, whether we are currently looking at closed or open issues/pull requests. My idea would be to switch to a red filter icon (tint) when viewing closed items.

The color values i used in the screenshot are:

R: 175

G: 66

B: 66

Edit: Made color values a little bit brighter than in the screenshot.

It would be nice too, if we would have some kind of indication, whether we are currently looking at closed or open issues/pull requests. My idea would be to switch to a red filter icon (tint) when viewing closed items. The color values i used in the screenshot are: R: 175 G: 66 B: 66 Edit: Made color values a little bit brighter than in the screenshot.
Poster
Owner

There are multiple progress bars when issues are being loaded.

I have only tested on issues using fastadapter. But it is not the focus right now as if PR works as I woulk like it to, I refactor issues to it too.

This is not a big problem, but in issues the list is empty while the progress bar spins. The opposite is true when pull requests are loading.

This need to be addressed, I will try to reproduce on my side.

It would be nice too, if we would have some kind of indication.

Yes, that's what I asked yesterday in the chat but good to know that you have posted a idea. I will try with that, just need to take care of the color in dark theme too.

> There are multiple progress bars when issues are being loaded. I have only tested on issues using fastadapter. But it is not the focus right now as if PR works as I woulk like it to, I refactor issues to it too. > This is not a big problem, but in issues the list is empty while the progress bar spins. The opposite is true when pull requests are loading. This need to be addressed, I will try to reproduce on my side. > It would be nice too, if we would have some kind of indication. Yes, that's what I asked yesterday in the chat but good to know that you have posted a idea. I will try with that, just need to take care of the color in dark theme too.
Poster
Owner

@opyale this commit has addressed your points. 3074c477b0

Aside that, I have worked on PR screen at the moment and focus is on that. Once all done on PR screen and we are going to accept these changes. I will refactor issues too in this same PR.

I will remove fastadapter from issues and later from commits, which means no more use of the library. Less space for the app.

Just need thorough testing on PR screen to address all the issues and make sure it works, which can then lead us to refactor issues.

@opyale this commit has addressed your points. https://gitea.com/gitnex/GitNex/commit/3074c477b097a534c0340326a0b30e89a04db72a Aside that, I have worked on PR screen at the moment and focus is on that. Once all done on PR screen and we are going to accept these changes. I will refactor issues too in this same PR. I will remove fastadapter from issues and later from commits, which means no more use of the library. Less space for the app. Just need thorough testing on PR screen to address all the issues and make sure it works, which can then lead us to refactor issues.
Collaborator

@mmarif This looks nice so far. The only bug i encountered was that if you swipe to another fragment after you've selected 'closed' on issues/prs and swipe back you will get a green filter icon though the content is still made up of closed views.

@mmarif This looks nice so far. The only bug i encountered was that if you swipe to another fragment after you've selected 'closed' on issues/prs and swipe back you will get a green filter icon though the content is still made up of closed views.
Collaborator

@mmarif And there is another bug: The color of the filter icon doesnt change when calling for some closed issues.

@mmarif And there is another bug: The color of the filter icon doesnt change when calling for some closed issues.
Poster
Owner

The only bug i encountered was that if you swipe to another fragment after you’ve selected ‘closed’ on issues/prs and swipe back you will get a green filter icon though the content is still made up of closed views.

Nice catch. Swipe even crash the app for me. Will fix that.

And there is another bug: The color of the filter icon doesnt change when calling for some closed issues.

Issues will be done later.

> The only bug i encountered was that if you swipe to another fragment after you’ve selected ‘closed’ on issues/prs and swipe back you will get a green filter icon though the content is still made up of closed views. Nice catch. Swipe even crash the app for me. Will fix that. > And there is another bug: The color of the filter icon doesnt change when calling for some closed issues. Issues will be done later.
Poster
Owner

Fixed the swipe issue. c3e1cf48b0

Fixed the swipe issue. https://gitea.com/gitnex/GitNex/commit/c3e1cf48b0a6d6e43de7b67b6135ab0c47569151
Collaborator

@mmarif Works fine now. Are you planning on fixing "issues" in this pr?

@mmarif Works fine now. Are you planning on fixing "issues" in this pr?
Poster
Owner

Are you planning on fixing “issues” in this pr?

Yes

> Are you planning on fixing “issues” in this pr? Yes
Poster
Owner

Refactored issues 141908ab49

Refactored issues https://gitea.com/gitnex/GitNex/commit/141908ab491542f205c943c5cc76ff5d86ef2c1a
Collaborator

@mmarif Is this your last commit, because I would start reviewing then.

@mmarif Is this your last commit, because I would start reviewing then.
Poster
Owner

Is this your last commit, because I would start reviewing then.

It litterly is as I can't find more things to add or fix.

> Is this your last commit, because I would start reviewing then. It litterly is as I can't find more things to add or fix.
Poster
Owner

@6543 do you want to try before I merge?

@6543 do you want to try before I merge?
Collaborator

sure - give me 20min I'll merge If it works on my side

sure - give me 20min I'll merge If it works on my side
Sign in to join this conversation.
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.