Does not show all my-repos #273

Closed
opened 2 years ago by 6543 · 13 comments
6543 commented 2 years ago
Collaborator

I think because of paggination (witch is added to 1.12.x) I can't view all my repos on GitNex

I think because of paggination (witch is added to 1.12.x) I can't view all my repos on GitNex
6543 added this to the 2.4.0 milestone 2 years ago
6543 added the
Bug
Upstream
labels 2 years ago
6543 closed this issue 2 years ago
Owner

@6543 I think it's not a bug, it should be under enhancement as it is introduced upstream in latest upcoming version.

Need to be implemented same as issues list.

@6543 I think it's not a bug, it should be under `enhancement` as it is introduced upstream in latest upcoming version. Need to be implemented same as issues list.
Poster
Collaborator

I would still count this as bug too since it worked in prefious versions!

I would still count this as bug too since it worked in prefious versions!
Poster
Collaborator

I'm thinking of report this as bug to upstream ?

so you that you still have a choice to use paggination or not!

I'm thinking of report this as bug to **upstream** ? so you that you still have a choice to use paggination or not!
Poster
Collaborator

@mmarif should I?

@mmarif should I?
Owner

Do you have the pr which added this?

Bdw you are right to have pagination or not. How many repos a user can have? 20, 30 or 50. That would not need pagination unless there are hundreds of repos.

Edit:
Some users can have many repos, maybe that is the case to introduce pagination. As it will be in 1.12 version. We will implement in the upcoming release of GitNex.

Do you have any information what are changed in the API level, just adding page parameter or anything else changed?

Do you have the pr which added this? Bdw you are right to have pagination or not. How many repos a user can have? 20, 30 or 50. That would not need pagination unless there are hundreds of repos. Edit: Some users can have many repos, maybe that is the case to introduce pagination. As it will be in 1.12 version. We will implement in the upcoming release of GitNex. *Do you have any information what are changed in the API level, just adding page parameter or anything else changed?*
Poster
Collaborator

its adding a query param: ?page=1

its adding a query param: `?page=1`
Poster
Collaborator

and limit "page size of results, maximum page size is 50"

and `limit` "page size of results, maximum page size is 50"
Owner

Can you confirm how many repositories the current app shows?

We can increase the limit to 50 and add page no. for 2.4.0 release to have as many repositories available. This will be easy to implement at this time. I believe default is 10.

One more thing the limit is 50 for repositories, is this the same for issues or only repositories?

Can you confirm how many repositories the current app shows? We can increase the limit to 50 and add page no. for 2.4.0 release to have as many repositories available. This will be easy to implement at this time. I believe default is 10. One more thing the limit is 50 for repositories, is this the same for issues or only repositories?
Poster
Collaborator

it's the limit for all paggination things on api

this is caused by: https://github.com/go-gitea/gitea/pull/9452

it's the limit for all paggination things on api this is caused by: https://github.com/go-gitea/gitea/pull/9452
Poster
Collaborator

@mmarif I'll make a upstream change to if you dont have query page it wont pagginate

@mmarif I'll make a upstream change to if you dont have query `page` it wont pagginate
Poster
Collaborator

Of course we should thing at utilize the paggination option

Of course we should thing at utilize the paggination option
Owner

Seems like you already opened a PR upstream. I was going to add page and limit param to all required APIs to see what it return on 1.11, 1.10 releases.

Bdw how many repos you see right now on 1.12-dev?

Seems like you already opened a PR upstream. I was going to add `page` and `limit` param to all required APIs to see what it return on 1.11, 1.10 releases. Bdw how many repos you see right now on 1.12-dev?
Poster
Collaborator

#279 resolfed the issue but I'll make it optional upstream to ...

#279 resolfed the issue but I'll make it optional upstream to ...
Sign in to join this conversation.
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.