#219 Long password generates 401

Closed
opened 2 months ago by 6543 · 13 comments
6543 commented 2 months ago

Created By: @TB1234

Description - describe the bug / feature / suggestion in brief : a long password (in may case > 60 character, multiple words, generated by KeePass seperated by space) generate a auth failed on login. If I change the password to a shorter one, the login works. The password is correct because I filled it with KeePass.

Expected behaviour - describe what should be the expected result : successfull login (200)

GitNex version : 2.2.2 / build 72

Gitea version : 1.10.0

Android version : LineageOS 16.0-20191126-NIGHTLY (Anroid 9)

Screenshots - if any: ./.

Logs - if any : ./.

Created By: @TB1234 #### Description - describe the bug / feature / suggestion in brief : a long password (in may case > 60 character, multiple words, generated by KeePass seperated by space) generate a auth failed on login. If I change the password to a shorter one, the login works. The password is correct because I filled it with KeePass. #### Expected behaviour - describe what should be the expected result : successfull login (200) #### GitNex version : 2.2.2 / build 72 #### Gitea version : 1.10.0 #### Android version : LineageOS 16.0-20191126-NIGHTLY (Anroid 9) #### Screenshots - if any: ./. #### Logs - if any : ./.
6543 added the
Bug
label 2 months ago
6543 closed this issue 2 months ago
mmarif commented 2 months ago
Owner

Can you share a test password here(not your actual password) so I can test it. Almost similar to the one which generate 401 error.

Can you share a test password here(not your actual password) so I can test it. Almost similar to the one which generate 401 error.
6543 commented 2 months ago
Poster

Created By: @TB1234

Hello,

yes, here is my old one, which did not work until I changed it to a new, shorter one (whitout quotes): “anhäkeln sonntäglich Kinderbuchautorin Grundausstattung Seraphim Schabbes verschwörerisch”

Created By: @TB1234 Hello, yes, here is my old one, which did not work until I changed it to a new, shorter one (whitout quotes): "anhäkeln sonntäglich Kinderbuchautorin Grundausstattung Seraphim Schabbes verschwörerisch"
mmarif commented 2 months ago
Owner

I am away right now to test it. But you have special characters which may not be the problem. But space maybe a problem, can remove the space and try.

I am away right now to test it. But you have special characters which may not be the problem. But space maybe a problem, can remove the space and try.
6543 commented 2 months ago
Poster

Created By: @TB1234

It looks like it is a problem with some special character. But I did not find out which character create the problem.

I cannot use my old password (I posted above) because it does not match the complexity rule. If I use another password and add space or the special german chars, it works. If I create a password with a lot of special characters (?:^>...) it does not work in some cases. In other cases the same characters does work.

So I cannot say what is the character or the string, which create realy the problem :-/

Created By: @TB1234 It looks like it is a problem with some special character. But I did not find out which character create the problem. I cannot use my old password (I posted above) because it does not match the complexity rule. If I use another password and add space or the special german chars, it works. If I create a password with a lot of special characters (?:^>...) it does not work in some cases. In other cases the same characters does work. So I cannot say what is the character or the string, which create realy the problem :-/
mmarif commented 2 months ago
Owner

@TB1234 GitNex 2.4.1 just released and maybe have fixed your problem with password. Can you help update the app(play store, f-droid takes few days) to let us know if it fixed the problem for you.

@TB1234 GitNex 2.4.1 just released and maybe have fixed your problem with password. Can you help update the app(play store, f-droid takes few days) to let us know if it fixed the problem for you.
6543 commented 2 months ago
Poster

Created By: @TB1234

Hey,

no, still does not work. I got again a 401...

I changed the password to: “Anhäkeln sonntäglich Kinderbuchautorin Grundausstattung Seraphim Schabbes verschwörerisch!1”

Created By: @TB1234 Hey, no, still does not work. I got again a 401... I changed the password to: "Anhäkeln sonntäglich Kinderbuchautorin Grundausstattung Seraphim Schabbes verschwörerisch!1"
mmarif commented 2 months ago
Owner

That’s unfortunate.

One request, I have removed the spaces and special characters, can you try this?

AnhkelnsonntglichKinderbuchautorinGrundausstattungSeraphimSchabbesverschwrerisch!1

Trying to find out the exact reason.

That's unfortunate. One request, I have removed the spaces and special characters, can you try this? `AnhkelnsonntglichKinderbuchautorinGrundausstattungSeraphimSchabbesverschwrerisch!1` Trying to find out the exact reason.
6543 commented 2 months ago
Poster

Created By: @TB1234

It works.

I changes it to:

AnhkelnsonntglichKinderbuchautorinGrundausstattungSeraphimSchabbesverschwrerisch!1ö

and got a 401... So the problems are the german special chars...

Created By: @TB1234 It works. I changes it to: `AnhkelnsonntglichKinderbuchautorinGrundausstattungSeraphimSchabbesverschwrerisch!1ö` and got a 401... So the problems are the german special chars...
mmarif commented 2 months ago
Owner

Thank you, this will help us fix the issue.

A contributor send a PR(#298) to fix, but it did not work in this case.

Thank you, this will help us fix the issue. A contributor send a PR(#298) to fix, but it did not work in this case.
mmarif commented 2 months ago
Owner

Hi @TB1234

I have just tested the app version 2.4.1 with the following passwords and it worked. The fix introduced in #298 is working(tested with and without).

AnhkelnsonntglichKinderbuchautrschwrerisch!1öorinGrundausstattungSeraphimSchabbesve

An ch!1öori bbesve

Can you tell us if you are on 2.4.1 not 2.4.0 version? and what Gitea version?

Hi @TB1234 I have just tested the app version 2.4.1 with the following passwords and it worked. The fix introduced in #298 is working(tested with and without). `AnhkelnsonntglichKinderbuchautrschwrerisch!1öorinGrundausstattungSeraphimSchabbesve` `An ch!1öori bbesve` Can you tell us if you are on 2.4.1 not 2.4.0 version? and what Gitea version?
6543 commented 2 months ago
Poster

Created By: @TB1234

It’s 2.4.0...

I reinstalled the Programm but only got the 2.4.0

Created By: @TB1234 It's 2.4.0... I reinstalled the Programm but only got the 2.4.0
6543 commented 2 months ago
Poster

Created By: @TB1234

Ah now I got it! Now it worked!

Created By: @TB1234 Ah now I got it! Now it worked!
mmarif commented 2 months ago
Owner

Thank you for the confirmation. I will close this issue now.

Thank you for the confirmation. I will close this issue now.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.