Planned downtime from 11:00 UTC to 11:30 UTC. We try to keep it as short as possible!

#191 [Bug] Cant Create issue

Closed
opened 2 months ago by 6543 · 11 comments
6543 commented 2 months ago

GitNex version : Current

Gitea version : 1.11.0-dev (gitea.com)

-> 1.9.5 works ...

I’ll debug it later

#### GitNex version : Current #### Gitea version : 1.11.0-dev (gitea.com) -> 1.9.5 works ... I'll debug it later
6543 added this to the 2.3.0 milestone 2 months ago
6543 added the
API
label 2 months ago
6543 added the
Bug
label 2 months ago
6543 added the
Upstream
label 2 months ago
6543 closed this issue 2 months ago
6543 self-assigned this 2 months ago
mmarif commented 2 months ago
Owner

Yup, tested on 1.9.x and it works.

Yup, tested on 1.9.x and it works.
6543 commented 2 months ago
Poster

response: Response{protocol=http/1.1, code=422, message=Unprocessable Entity, url=https://gitea.com/api/v1/repos/test-organisation/TestRepo/issues}

response: `Response{protocol=http/1.1, code=422, message=Unprocessable Entity, url=https://gitea.com/api/v1/repos/test-organisation/TestRepo/issues}`
mmarif commented 2 months ago
Owner

Anything changed in this API recently?

Anything changed in this API recently?
6543 commented 2 months ago
Poster

found it:

“assignees”: [ "” ], has to be removed from json if empty!

-> 1.9.x && 1.10.0-rc2 ignore "assignees": [ "" ],
but 1.11-dev does not

found it: "assignees": [ "" ], has to be removed from json if empty! -> 1.9.x && 1.10.0-rc2 ignore ` "assignees": [ "" ],` but 1.11-dev does not
mmarif commented 2 months ago
Owner

So it is an upstream bug?

So it is an upstream bug?
6543 commented 2 months ago
Poster
created issue: https://github.com/go-gitea/gitea/issues/8872
6543 commented 2 months ago
Poster

@mmarif i dont know jet if this was intended or not ...

@mmarif i dont know jet if this was intended or not ...
mmarif commented 2 months ago
Owner

It should not be as assignees are optional when creating an issue.

It should not be as assignees are optional when creating an issue.
6543 commented 2 months ago
Poster
bugfix PR is send https://github.com/go-gitea/gitea/pull/8873
mmarif commented 2 months ago
Owner

That was fast. 👏👏👏

That was fast. 👏👏👏
6543 commented 2 months ago
Poster

@mmarif Fix merged upstream ... I’ll close this

@mmarif Fix merged upstream ... I'll close this
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.