i3 plugin does not update workspace view #2

Closed
opened 2 years ago by ashimokawa · 4 comments

When I start yambar everything is fine, it reflects the current workspace state (active workspaces, names, etc), but the state is never changed, the view is just frozen and never updates.

I did no debugging so far, sorry :/

When I start yambar everything is fine, it reflects the current workspace state (active workspaces, names, etc), but the state is never changed, the view is just frozen and never updates. I did no debugging so far, sorry :/
Owner

No worries. I switched to Wayland a while ago and haven't really used the X11 backend since.

I believe the problem is that the handler for a 'window change' event assumed the event had a 'pid' property. This is a non-standard property not listed in https://i3wm.org/docs/ipc.html that Sway provides, but apparently not i3.

Would you mind testing #3?

No worries. I switched to Wayland a while ago and haven't really used the X11 backend since. I believe the problem is that the handler for a 'window change' event assumed the event had a 'pid' property. This is a non-standard property not listed in https://i3wm.org/docs/ipc.html that Sway provides, but apparently not i3. Would you mind testing https://codeberg.org/dnkl/yambar/pulls/3?
dnkl self-assigned this 2 years ago
Poster

@dnkl
Sure, I will test tonight!

@dnkl Sure, I will test tonight!
Poster

@dnkl
Yep, confirmed working 👍
Thanks!

@dnkl Yep, confirmed working :+1: Thanks!
dnkl closed this issue 2 years ago
Owner

Great! Thanks for helping out with testing!

Great! Thanks for helping out with testing!
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.