Failed to build with GCC 12 and Fedora 36 #96

Closed
opened 6 months ago by atim · 4 comments
atim commented 6 months ago

Hello.

/usr/include/librsvg-2.0/librsvg/rsvg.h:125:66: error: "/*" within comment [-Werror=comment]
  125 |  * included through XML entities) if those files are in `/foo/bar/*` or in `/foo/bar/*\/.../*`.

https://gcc.gnu.org/gcc-12/porting_to.html

Hello. ```c /usr/include/librsvg-2.0/librsvg/rsvg.h:125:66: error: "/*" within comment [-Werror=comment] 125 | * included through XML entities) if those files are in `/foo/bar/*` or in `/foo/bar/*\/.../*`. ``` - [Full build log](https://kojipkgs.fedoraproject.org//work/tasks/190/81980190/build.log). - GCC ver: `12.0.1-0.3.fc36` https://gcc.gnu.org/gcc-12/porting_to.html
Owner

That error points into a system installed livrsvg header file. I.e. the issue is in librsvg, not fuzzel.

That error points into a system installed livrsvg header file. I.e. the issue is in librsvg, not fuzzel.
dnkl closed this issue 6 months ago
dnkl added the
invalid
label 6 months ago
Owner

note: you can disable the use of librsvg, and use the built-in nanosvg backend instead, with the -Dsvg-backend meson command line option.

note: you can disable the use of librsvg, and use the built-in nanosvg backend instead, with the `-Dsvg-backend` meson command line option.
Poster

@dnkl thank you. Built with nanosvg for now on f36.

@dnkl thank you. [Built](https://koji.fedoraproject.org/koji/taskinfo?taskID=82197890) with `nanosvg` for now on f36.
Owner

Built with nanosvg for now on f36.

This will be the default in the next fuzzel release.

> Built with nanosvg for now on f36. This will be the default in the next fuzzel release.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: dnkl/fuzzel#96
Loading…
There is no content yet.