Copying "nothingness" results in lots of newlines #97

Closed
opened 1 year ago by dnkl · 0 comments
dnkl commented 1 year ago
Owner

Copying large blocks of empty cells results in newlines, when it should result in "nothing".

With #84 merged, this is now much more obvious; the visible selection doesn't match what gets copied.

The problem is here, where we are trying to detect whether we should insert a newline in the copied text or not (i.e. "reflow") when moving from one row to another.

Copying large blocks of empty cells results in newlines, when it should result in "nothing". With https://codeberg.org/dnkl/foot/pulls/84 merged, this is now much more obvious; the visible selection doesn't match what gets copied. The problem is [here](https://codeberg.org/dnkl/foot/src/commit/c0ddb78f4ac05a8dbaf103602e1e6a38e98d4388/extract.c#L122), where we are trying to detect whether we should insert a newline in the copied text or not (i.e. "reflow") when moving from one row to another.
dnkl added the
bug
label 1 year ago
dnkl closed this issue 1 year ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.