failed to render glyph: cannot render this glyph format #735

Closed
opened 2 months ago by striker.sh · 4 comments

I have been having issue lately with my favorite font Dina and foot.
It was working perfectly before, so I tried converting the bdf to otb, then to pcf and everytime got the following message (with the corresponding font format).

The issue makes characters not render at all (shouldn't it fallback to another font in this case?)

info: main.c:398: version: 1.8.1 -pgo -ime +graphemes
info: main.c:406: arch: Linux x86_64/64-bit
info: main.c:412: locale: en_US.utf8
info: config.c:2932: loading configuration from /home/striker/.config/foot/foot.ini
info: wayland.c:1229: DP-3: 1920x1200+0x0@60Hz DELL U2410 24.04" scale=1 PPI=96x100 (physical) PPI=96x100 (logical), DPI=94.19
info: wayland.c:1375: requesting SSD decorations
info: fcft.c:266: fcft: 2.4.1 +graphemes +runs
info: fcft.c:276: fontconfig: 2.13.1
info: fcft.c:282: freetype: 2.11.0
info: info: fcft.c:758: fcft.c:758: /home/striker/.local/share/fonts/Dina_r700-8.pcf: size=8.00pt/10px, dpi=94.19
/home/striker/.local/share/fonts/Dina_r400-8.pcf: size=8.00pt/10px, dpi=94.19
info: fcft.c:758: /home/striker/.local/share/fonts/Dina_i700-8.pcf: size=8.00pt/10px, dpi=94.19
info: fcft.c:758: /home/striker/.local/share/fonts/Dina_i400-8.pcf: size=8.00pt/10px, dpi=94.19
info: terminal.c:681: cell width=7, height=13
info: terminal.c:583: using 16 rendering threads
info: wayland.c:760: using SSD decorations
info: wayland.c:1518: cursor theme: Adwaita, size: 16, scale: 1
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format
I have been having issue lately with my favorite font Dina and foot. It was working perfectly before, so I tried converting the bdf to otb, then to pcf and everytime got the following message (with the corresponding font format). The issue makes characters not render at all (shouldn't it fallback to another font in this case?) ``` info: main.c:398: version: 1.8.1 -pgo -ime +graphemes info: main.c:406: arch: Linux x86_64/64-bit info: main.c:412: locale: en_US.utf8 info: config.c:2932: loading configuration from /home/striker/.config/foot/foot.ini info: wayland.c:1229: DP-3: 1920x1200+0x0@60Hz DELL U2410 24.04" scale=1 PPI=96x100 (physical) PPI=96x100 (logical), DPI=94.19 info: wayland.c:1375: requesting SSD decorations info: fcft.c:266: fcft: 2.4.1 +graphemes +runs info: fcft.c:276: fontconfig: 2.13.1 info: fcft.c:282: freetype: 2.11.0 info: info: fcft.c:758: fcft.c:758: /home/striker/.local/share/fonts/Dina_r700-8.pcf: size=8.00pt/10px, dpi=94.19 /home/striker/.local/share/fonts/Dina_r400-8.pcf: size=8.00pt/10px, dpi=94.19 info: fcft.c:758: /home/striker/.local/share/fonts/Dina_i700-8.pcf: size=8.00pt/10px, dpi=94.19 info: fcft.c:758: /home/striker/.local/share/fonts/Dina_i400-8.pcf: size=8.00pt/10px, dpi=94.19 info: terminal.c:681: cell width=7, height=13 info: terminal.c:583: using 16 rendering threads info: wayland.c:760: using SSD decorations info: wayland.c:1518: cursor theme: Adwaita, size: 16, scale: 1 err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format err: fcft.c:1268: /home/striker/.local/share/fonts/Dina_r400-8.pcf: failed to render glyph: cannot render this glyph format ```
Poster

Just tried with terminus and got the same results

also I'm on this version:

foot version: 1.8.1 -pgo -ime +graphemes
Just tried with terminus and got the same results also I'm on this version: ``` foot version: 1.8.1 -pgo -ime +graphemes ```
Owner

This is caused by a bug introduced in FreeType 2.11.

A workaround was added to fcft 2.4.4 (i.e not foot itself).

Either update fcft (you're currently on 2.4.1), or downgrade FreeType.

It may also have been fixed, or will be fixed, ina newer FreeType release.

This is caused by a bug introduced in FreeType 2.11. A workaround was added to fcft 2.4.4 (i.e **not** foot itself). Either update fcft (you're currently on 2.4.1), or downgrade FreeType. It _may_ also have been fixed, or will be fixed, ina newer FreeType release.
striker.sh closed this issue 2 months ago
Owner

Duplicate of dnkl/fcft#29

Duplicate of https://codeberg.org/dnkl/fcft/issues/29
dnkl added the
duplicate
label 2 months ago
Owner

Btw, nice to see a fellow Dina user!

Btw, nice to see a fellow Dina user!
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.