Cannot run powertop #694

Closed
opened 3 months ago by flipflop133 · 5 comments

Since foot 1.9 powertop won't open anymore.

modprobe cpufreq_stats failedLoaded 680 prior measurements
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask d
RAPL device for cpu 0
RAPL Using PowerCap Sysfs : Domain Mask d
Devfreq not enabled
glob returned GLOB_ABORTED
Error opening terminal: foot.
Since foot 1.9 powertop won't open anymore. ``` modprobe cpufreq_stats failedLoaded 680 prior measurements RAPL device for cpu 0 RAPL Using PowerCap Sysfs : Domain Mask d RAPL device for cpu 0 RAPL Using PowerCap Sysfs : Domain Mask d Devfreq not enabled glob returned GLOB_ABORTED Error opening terminal: foot. ```
Poster

I think this is related too:
If I export foot in .zprofile like so:
export EDITOR="nvim"
I get the following error:
can't find terminal definition for foot
Hope that this isn't related to this
https://codeberg.org/dnkl/foot#programmatically-checking-if-running-in-foot
"Foot does not set any environment variables that can be used to identify foot..."

I think this is related too: If I export foot in .zprofile like so: `export EDITOR="nvim"` I get the following error: `can't find terminal definition for foot` Hope that this isn't related to this https://codeberg.org/dnkl/foot#programmatically-checking-if-running-in-foot "Foot does not set any environment variables that can be used to identify foot..."
Owner

I assume you run powertop with sudo, or doas? Then it's a duplicate of #691 and #692.

See #671 for background.

There's also #695, which tracks all issues seen so far, and may result in a change of how we handle terminfos.

TL;DR foot now installs its terminfo definitions in a non-standard location and exports TERMINFO, in order to be able to co-exist with the next ncurses release, which will include its own (less capable) terminfo definitions for foot.

I assume you run `powertop` with `sudo`, or `doas`? Then it's a duplicate of https://codeberg.org/dnkl/foot/issues/691 and https://codeberg.org/dnkl/foot/issues/692. See https://codeberg.org/dnkl/foot/issues/671 for background. There's also https://codeberg.org/dnkl/foot/issues/695, which tracks all issues seen so far, and may result in a change of how we handle terminfos. TL;DR foot now installs its terminfo definitions in a non-standard location and exports `TERMINFO`, in order to be able to co-exist with the next ncurses release, which will include its own (less capable) terminfo definitions for foot.
Poster

Ok my bad I haven't saw the issues, thanks for explanations and references, works fine now.

Ok my bad I haven't saw the issues, thanks for explanations and references, works fine now.
flipflop133 closed this issue 3 months ago
Owner

If I export foot in .zprofile like so:
export EDITOR="nvim"
I get the following error:
can't find terminal definition for foot

I'm not sure I follow... What exactly are you doing? You mention "exporting foot", but all I see is EDITOR=nvim.

It's obviously related to the terminfo changes in 1.9.0, but just trying to understand what exactly is happening here.

> If I export foot in .zprofile like so: > `export EDITOR="nvim"` > I get the following error: > can't find terminal definition for foot I'm not sure I follow... What exactly are you doing? You mention "exporting foot", but all I see is `EDITOR=nvim`. It's obviously related to the terminfo changes in 1.9.0, but just trying to understand what exactly is happening here.
Poster

It's on me I copied the wrong line in my opened issue, the right line is:
export TERM="foot"
Which seems to work because in sway config I'm then using $TERM and my config seems to work fine.

It's on me I copied the wrong line in my opened issue, the right line is: `export TERM="foot"` Which seems to work because in sway config I'm then using $TERM and my config seems to work fine.
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.