Foot doesnt work woth powerlevel10k instant prompt properly #558

Closed
opened 6 months ago by ibrokemypie · 2 comments

I use the zsh theme powerlevel10k which has an instant prompt functionality. Additionally I print my zsh init time when zsh is started. This results in the following most of the time when starting foot (in sway if that matters)
image
image

When it should (and does in other terminals) look like this
image

This doesnt happen 100% of the time and isn't a major issue, but it happens most of the time and is a minor annoyance that I can't reproduce in other terminals I use.

I use the zsh theme powerlevel10k which has an instant prompt functionality. Additionally I print my zsh init time when zsh is started. This results in the following most of the time when starting foot (in sway if that matters) ![image](/attachments/3ca05c64-4416-44f1-8769-7c698a213b21) ![image](/attachments/4a21fcdf-956e-455d-9b98-a636677b4029) When it should (and does in other terminals) look like this ![image](/attachments/38b5d7f0-fa4f-41f4-a576-185ca970ff34) This doesnt happen 100% of the time and isn't a major issue, but it happens most of the time and is a minor annoyance that I can't reproduce in other terminals I use.
Owner

Duplicate of #195, and #265.

To fix this, either the shell needs to handle early terminal window resizes better, or we need to implement the "wait-for-mapped" workaround mentioned in #453.

And, fwiw, other terminals are affected by this. See for example https://github.com/alacritty/alacritty/issues/1616

Duplicate of https://codeberg.org/dnkl/foot/issues/195, and https://codeberg.org/dnkl/foot/issues/265. To fix this, either the shell needs to handle early terminal window resizes better, or we need to implement the "wait-for-mapped" workaround mentioned in https://codeberg.org/dnkl/foot/issues/453. And, fwiw, other terminals _are_ affected by this. See for example https://github.com/alacritty/alacritty/issues/1616
Owner

foot may be more susceptible because it both starts up very fast, and is very aggressive about starting the shell as early as possible.

foot may be more susceptible because it both starts up **very** fast, **and** is very aggressive about starting the shell as early as possible.
dnkl closed this issue 6 months ago
dnkl added the
duplicate
label 6 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.