Pasting from the wyeb browser menu does not work in foot #291

Closed
opened 9 months ago by FoundOne · 1 comments

How to reproduce it:

  1. Right click on any link in wyeb to open the context menu.
  2. Choose the "Copy link location" option.
  3. Select a foot instance.
  4. Press Ctrl+Shift+V

What happens:
Nothing happens.

What should happen:
It should paste the link url in the terminal.

Remark:
I was not sure whether to report it as a foot bug or a wyeb bug, but the paste works for other applications (I tried alacritty, qtox and wl-paste), so I decided to report it here. I suspect it has something to do with the seats, but I'm not sure. The bug only happens with the context menu.

wyeb is a minimalist scriptable web browser with vi key bindings based on webkit2gtk.
https://github.com/jun7/wyeb

How to reproduce it: 1. Right click on any link in wyeb to open the context menu. 2. Choose the "Copy link location" option. 3. Select a foot instance. 4. Press Ctrl+Shift+V What happens: Nothing happens. What should happen: It should paste the link url in the terminal. Remark: I was not sure whether to report it as a foot bug or a wyeb bug, but the paste works for other applications (I tried alacritty, qtox and wl-paste), so I decided to report it here. I suspect it has something to do with the seats, but I'm not sure. The bug only happens with the context menu. wyeb is a minimalist scriptable web browser with vi key bindings based on webkit2gtk. https://github.com/jun7/wyeb
dnkl added the
bug
label 9 months ago
Owner

This is on foot. wyeb is offering the mime-type text/uri-list, which foot accepts. The problem is when receiving the data; foot assumes all URIs are newline terminated (that's what all other browsers and file managers I've tested do), but wyeb sends a single URI without a newline.

Should be easy to fix in foot.

This is on foot. wyeb is offering the mime-type `text/uri-list`, which foot accepts. The problem is when receiving the data; foot assumes all URIs are newline terminated (that's what all other browsers and file managers I've tested do), but wyeb sends a single URI **without** a newline. Should be easy to fix in foot.
dnkl closed this issue 9 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.