word-delimiters option ignores # and subsequent characters #270

Closed
opened 10 months ago by pc · 1 comments
pc commented 10 months ago

Before describing the issue, thank you very much for creating foot. Your work fills a void in the Wayland ecosystem and is the first terminal emulator to fully substitute urxvt. I was particularly excited to see #198 and #267 resolved.

I translated my word delimiters from urxvt to foot.ini as follows:

# https://utcc.utoronto.ca/~cks/space/blog/unix/UrxvtNotes
word-delimiters=\`"'&()*,;<=>?@[]^{|}.#%+!/:-

This did not quite yield the intended behaviour since # is treated as the comment delimiter. At the expense of slightly breaking backwards-compatibility, could we require a preceding blank (space or tab) for a trailing comment?

Before describing the issue, thank you very much for creating foot. Your work fills a void in the Wayland ecosystem and is the first terminal emulator to fully substitute urxvt. I was particularly excited to see #198 and #267 resolved. I translated my word delimiters from urxvt to `foot.ini` as follows: ```text # https://utcc.utoronto.ca/~cks/space/blog/unix/UrxvtNotes word-delimiters=\`"'&()*,;<=>?@[]^{|}.#%+!/:- ``` This did not quite yield the intended behaviour since `#` is treated as the comment delimiter. At the expense of slightly breaking backwards-compatibility, could we require a preceding blank (space or tab) for a trailing comment?
Owner

At the expense of slightly breaking backwards-compatibility, could we require a preceding blank (space or tab) for a trailing comment?

Yes, I think that would be ok.

Before describing the issue, thank you very much for creating foot. Your work fills a void in the Wayland ecosystem and is the first terminal emulator to fully substitute urxvt.

Thanks! It does help with the motivation to hear things like this from time to time :)

> At the expense of slightly breaking backwards-compatibility, could we require a preceding blank (space or tab) for a trailing comment? Yes, I think that would be ok. > Before describing the issue, thank you very much for creating foot. Your work fills a void in the Wayland ecosystem and is the first terminal emulator to fully substitute urxvt. Thanks! It does help with the motivation to hear things like this from time to time :)
dnkl added the
bug
label 10 months ago
dnkl closed this issue 10 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.