Sequence sent for Ctrl+Shift+Tab is the same as Shift+Tab #210

Closed
opened 11 months ago by craigbarnes · 3 comments
Collaborator

I'm loving the fact that foot sends some modifyOtherKey-style keycodes by default. I've never seen other terminals do that, but I've been wishing for ages they would.

One minor thing I've noticed though is that Ctrl+Shift+Tab seems to send the same code as Shift+Tab (i.e. CSI Z), rather than CSI 27;6;9 ~. Is that intentional?

I'm loving the fact that `foot` sends some `modifyOtherKey`-style keycodes by default. I've never seen other terminals do that, but I've been wishing for ages they would. One minor thing I've noticed though is that Ctrl+Shift+Tab seems to send the same code as Shift+Tab (i.e. `CSI Z`), rather than `CSI 27;6;9 ~`. Is that intentional?
dnkl added the
bug
label 11 months ago
Owner

No, that wasn't intentional at all. Good find!

The issue is that Shift+Tab returns a different XKB key symbol than plain Tab.

Foot uses two different lookup tables for the two. The table for Tab is correctly populated, but the Shift+Tab table maps all combos to CSI Z.

No, that wasn't intentional at all. Good find! The issue is that <kbd>Shift</kbd>+<kbd>Tab</kbd> returns a different XKB key symbol than plain <kbd>Tab</kbd>. Foot uses two different lookup tables for the two. The table for <kbd>Tab</kbd> is correctly populated, but the <kbd>Shift</kbd>+<kbd>Tab</kbd> table maps all combos to `CSI Z`.
dnkl closed this issue 11 months ago
Poster
Collaborator
Thanks, working great now. [https://gitlab.com/craigbarnes/dte/-/commit/2a3e5a9a53cdd247de30f832e35c972a32c0ca49](https://gitlab.com/craigbarnes/dte/-/commit/2a3e5a9a53cdd247de30f832e35c972a32c0ca49)
Owner

Nice to see it being used :)

Nice to see it being used :)
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.