Sometimes slow resizing when window isn't visible #190

Closed
opened 12 months ago by sammoth · 3 comments

foot version 1.5.3-169-g3fa3c58
sway version 1.5-bf9cfe4e

Hi, in sway foot seems to be very slow to resize when its window is hidden behind another, sometimes.

For example on a clear workspace, open two foot instances side-by-side and use the mouse to resize the panes. They both resize fast and everything redraws at a high framerate.

Then open a third foot instance tabbed together with one of the existing panes.

         |Horizontal
     --------
Tab |        |
 ------      f
 f    f

Now one foot instance is hidden but still resizes when you resize the horizontal split. The resizing is very laggy, redrawing maybe 2 times per second.

foot version 1.5.3-169-g3fa3c58 sway version 1.5-bf9cfe4e Hi, in sway foot seems to be very slow to resize when its window is hidden behind another, sometimes. For example on a clear workspace, open two foot instances side-by-side and use the mouse to resize the panes. They both resize fast and everything redraws at a high framerate. Then open a third foot instance tabbed together with one of the existing panes. ``` |Horizontal -------- Tab | | ------ f f f ``` Now one foot instance is hidden but still resizes when you resize the horizontal split. The resizing is very laggy, redrawing maybe 2 times per second.
Owner

Verified. It is really slow. I think I know what the problem is, and will put up a PR soon (I hope :)).

Verified. It is **really** slow. I think I know what the problem is, and will put up a PR soon (I hope :)).
dnkl added the
bug
label 12 months ago
dnkl self-assigned this 12 months ago
Owner

@sammoth feel free to test #192. I'll have to test it on more compositors before I can merge it, but it solves the problem on Sway at least.

@sammoth feel free to test https://codeberg.org/dnkl/foot/pulls/192. I'll have to test it on more compositors before I can merge it, but it solves the problem on Sway at least.
Poster

Thank you, that was fast! Yes the fix seems to work well.

Thank you, that was fast! Yes the fix seems to work well.
dnkl closed this issue 12 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.