Resizing foot loses scrollback position #142

Closed
opened 1 year ago by JorwLNKwpH · 2 comments

Tested on sway, but this should affect other tiling compositors at least.

Whenever foot is resized, the scrollback position is lost.

Tested on sway, but this should affect other tiling compositors at least. Whenever foot is resized, the scrollback position is lost.
dnkl commented 1 year ago
Owner

For what it's worth, this is by design. But, it's a design choice that was made while foot's text reflower was much less capable.

It should be possible to fix this in a sensible way now, and given the usability improvements it would result in, I'd say it's definitely worth spending some time on this.

For what it's worth, this is by design. But, it's a design choice that was made while foot's text reflower was much less capable. It should be possible to fix this in a sensible way now, and given the usability improvements it would result in, I'd say it's definitely worth spending some time on this.
dnkl added the
bug
label 1 year ago
dnkl commented 1 year ago
Owner

I would really appreciate some testing of #143

I would _really_ appreciate some testing of https://codeberg.org/dnkl/foot/pulls/143
dnkl closed this issue 1 year ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.