The lower right text box in scrollback search mode is blacked out #1112

Closed
opened 4 months ago by Pound_Hash · 5 comments

The problem
20288


20358


20412


My colorscheme

foreground=000000
background=fafafa

regular0=000000  # black
regular1=800000  # red
regular2=000000  # green
regular3=000000  # yellow
regular4=000099  # blue
regular5=000000  # magenta
regular6=000000  # cyan
regular7=fafafa  # white

bright0=000000   # black
bright1=800000   # red
bright2=000000   # green
bright3=000000   # yellow
bright4=000099   # blue
bright5=000000   # magenta
bright6=000000   # cyan
bright7=fafafa   # white

dim0=<not set>
...
dim7=<not-set>

selection-foreground=fcfcfc
selection-background=363649
jump-labels=ffffff 666666
urls=000000
**The problem** <a href="https://postimages.org/" target="_blank"><img src="https://i.postimg.cc/rscLQRnQ/20288.png" alt="20288"/></a><br/><br/> <a href="https://postimages.org/" target="_blank"><img src="https://i.postimg.cc/pVYvykr7/20358.png" alt="20358"/></a><br/><br/> <a href="https://postimages.org/" target="_blank"><img src="https://i.postimg.cc/90pHSXsV/20412.png" alt="20412"/></a><br/><br/> ----- **My colorscheme** ``` foreground=000000 background=fafafa regular0=000000 # black regular1=800000 # red regular2=000000 # green regular3=000000 # yellow regular4=000099 # blue regular5=000000 # magenta regular6=000000 # cyan regular7=fafafa # white bright0=000000 # black bright1=800000 # red bright2=000000 # green bright3=000000 # yellow bright4=000099 # blue bright5=000000 # magenta bright6=000000 # cyan bright7=fafafa # white dim0=<not set> ... dim7=<not-set> selection-foreground=fcfcfc selection-background=363649 jump-labels=ffffff 666666 urls=000000 ```
Owner

Is this on GNOME? I believe the issue is in which order the compositor renders the sub-surfaces used by foot.

That said, I think this is fixable on the foot side, by excluding the text box area from the dimmed overlay.

Is this on GNOME? I believe the issue is in which order the compositor renders the sub-surfaces used by foot. That said, I think this is fixable on the foot side, by excluding the text box area from the dimmed overlay.
Poster

Is this on GNOME?

No, it's Sway.

> Is this on GNOME? No, it's Sway.
Owner

Hold on... this is not a rendering issue, but a simple color scheme issue. The scrollback search box fg/bg colors are probably the only colors that can't be configured in foot, but are instead hardcoded to use colors from your color scheme.

The bg color used while it's empty, and when it's matching, is "yellow" (which in your scheme is #000000 - black). The fg is "black", which also is #000000 in your scheme. Hence you have black-on-black.

The fix is to add config options to allow overriding the search box colors.

Hold on... this is not a rendering issue, but a simple color scheme issue. The scrollback search box fg/bg colors are probably the only colors that can't be configured in foot, but are instead hardcoded to use colors from your color scheme. The bg color used while it's empty, and when it's matching, is "yellow" (which in your scheme is `#000000` - black). The fg is "black", which also is `#000000` in your scheme. Hence you have black-on-black. The fix is to add config options to allow overriding the search box colors.
dnkl added the
enhancement
label 4 months ago
Poster

Yeah, I'm colorblind. I can't use so many colors.

Yeah, I'm colorblind. I can't use so many colors.
dnkl closed this issue 4 months ago
Poster

Just got the update. Works great. Thanks!

Just got the update. Works great. Thanks!
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: dnkl/foot#1112
Loading…
There is no content yet.