Crash of CCTG 2.23.2.0 on Android 7.0 #267

Closed
opened 2 months ago by d1234 · 2 comments
d1234 commented 2 months ago

CCTG crashes directly on startup of the app.

06-16 17:25:13.169  9229  9229 E AndroidRuntime: FATAL EXCEPTION: main
06-16 17:25:13.169  9229  9229 E AndroidRuntime: Process: de.corona.tracing, PID: 9229
06-16 17:25:13.169  9229  9229 E AndroidRuntime: java.lang.NoClassDefFoundError: Failed resolution of: Ljava/time/Instant;
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.serialization.SerializationModule$Companion$baseGson$2.i
nvoke(SerializationModule.kt:56)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.serialization.SerializationModule$Companion$baseGson$2.i
nvoke(SerializationModule.kt:54)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at kotlin.SynchronizedLazyImpl.getValue(LazyJVM.kt:74)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.serialization.SerializationModule$Companion.getBaseGson(
SerializationModule.kt:54)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.serialization.SerializationModule.baseGson(Serialization
Module.kt:36)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.serialization.SerializationModule_BaseGsonFactory.baseGs
on(SerializationModule_BaseGsonFactory.java:35)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.serialization.SerializationModule_BaseGsonFactory.get(Se
rializationModule_BaseGsonFactory.java:27)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.serialization.SerializationModule_BaseGsonFactory.get(Se
rializationModule_BaseGsonFactory.java:9)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at dagger.internal.SingleCheck.get(SingleCheck.java:49)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.submission.SubmissionSettings_Factory.get(SubmissionSettings_
Factory.java:32)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.submission.SubmissionSettings_Factory.get(SubmissionSettings_
Factory.java:10)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at dagger.internal.DoubleCheck.get(DoubleCheck.java:47)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.encryptionmigration.EncryptedPreferencesMigration_Factory.get(EncryptedPreferencesMigration_Factory.java:55)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.util.encryptionmigration.EncryptedPreferencesMigration_Factory.get(EncryptedPreferencesMigration_Factory.java:13)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at dagger.internal.DoubleCheck.get(DoubleCheck.java:47)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at de.rki.coronawarnapp.CoronaWarnApplication.onCreate(CoronaWarnApplication.kt:56)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1025)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at android.app.ActivityThread.handleBindApplication(ActivityThread.java:5491)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at android.app.ActivityThread.-wrap2(ActivityThread.java)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at java.lang.reflect.Method.invoke(Native Method)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:865)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:755)
06-16 17:25:13.169  9229  9229 E AndroidRuntime: Caused by: java.lang.ClassNotFoundException: Didn't find class "java.time.Instant" on path: DexPathList[[zip file "/data/app/de.corona.tracing-2/base.apk"],nativeLibraryDirectories=[/data/app/de.corona.tracing-2/lib/arm64, /data/app/de.corona.tracing-2/base.apk!/lib/arm64-v8a, /system/lib64, /vendor/lib64]]
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:56)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at java.lang.ClassLoader.loadClass(ClassLoader.java:380)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        at java.lang.ClassLoader.loadClass(ClassLoader.java:312)
06-16 17:25:13.169  9229  9229 E AndroidRuntime:        ... 26 more

I think it might be related to the issue described here:

https://github.com/Kotlin/kotlinx-datetime/issues/64

CCTG crashes directly on startup of the app. ``` 06-16 17:25:13.169 9229 9229 E AndroidRuntime: FATAL EXCEPTION: main 06-16 17:25:13.169 9229 9229 E AndroidRuntime: Process: de.corona.tracing, PID: 9229 06-16 17:25:13.169 9229 9229 E AndroidRuntime: java.lang.NoClassDefFoundError: Failed resolution of: Ljava/time/Instant; 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.serialization.SerializationModule$Companion$baseGson$2.i nvoke(SerializationModule.kt:56) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.serialization.SerializationModule$Companion$baseGson$2.i nvoke(SerializationModule.kt:54) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at kotlin.SynchronizedLazyImpl.getValue(LazyJVM.kt:74) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.serialization.SerializationModule$Companion.getBaseGson( SerializationModule.kt:54) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.serialization.SerializationModule.baseGson(Serialization Module.kt:36) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.serialization.SerializationModule_BaseGsonFactory.baseGs on(SerializationModule_BaseGsonFactory.java:35) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.serialization.SerializationModule_BaseGsonFactory.get(Se rializationModule_BaseGsonFactory.java:27) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.serialization.SerializationModule_BaseGsonFactory.get(Se rializationModule_BaseGsonFactory.java:9) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at dagger.internal.SingleCheck.get(SingleCheck.java:49) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.submission.SubmissionSettings_Factory.get(SubmissionSettings_ Factory.java:32) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.submission.SubmissionSettings_Factory.get(SubmissionSettings_ Factory.java:10) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at dagger.internal.DoubleCheck.get(DoubleCheck.java:47) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.encryptionmigration.EncryptedPreferencesMigration_Factory.get(EncryptedPreferencesMigration_Factory.java:55) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.util.encryptionmigration.EncryptedPreferencesMigration_Factory.get(EncryptedPreferencesMigration_Factory.java:13) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at dagger.internal.DoubleCheck.get(DoubleCheck.java:47) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at de.rki.coronawarnapp.CoronaWarnApplication.onCreate(CoronaWarnApplication.kt:56) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1025) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at android.app.ActivityThread.handleBindApplication(ActivityThread.java:5491) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at android.app.ActivityThread.-wrap2(ActivityThread.java) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at java.lang.reflect.Method.invoke(Native Method) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:865) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:755) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: Caused by: java.lang.ClassNotFoundException: Didn't find class "java.time.Instant" on path: DexPathList[[zip file "/data/app/de.corona.tracing-2/base.apk"],nativeLibraryDirectories=[/data/app/de.corona.tracing-2/lib/arm64, /data/app/de.corona.tracing-2/base.apk!/lib/arm64-v8a, /system/lib64, /vendor/lib64]] 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:56) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at java.lang.ClassLoader.loadClass(ClassLoader.java:380) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: at java.lang.ClassLoader.loadClass(ClassLoader.java:312) 06-16 17:25:13.169 9229 9229 E AndroidRuntime: ... 26 more ``` I think it might be related to the issue described here: https://github.com/Kotlin/kotlinx-datetime/issues/64
fynngodau referenced this issue from a commit 2 months ago
Owner

Thanks for bringing this to our attention. This was caused by classes missing because we disabled desugaring. We will release a fixed version soon.

Thanks for bringing this to our attention. This was caused by classes missing because we disabled desugaring. We will release a fixed version soon.
fynngodau added the
ready-to-close
label 2 months ago
Bubu closed this issue 3 weeks ago
Owner

This is fixed by version 2.24 now.

This is fixed by version 2.24 now.
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

No dependencies set.

Reference: corona-contact-tracing-germany/cwa-android#267
Loading…
There is no content yet.