Contact tracing isn't working on Android 12 #169

Open
opened 2 months ago by justCoding · 21 comments

Contact tracing isn't working on my device since I updated it to Android 12 (before the update I ran Android 11).

I'm using:

  • Google Pixel 4
  • latest Android 12
  • CCTG 2.11.2
  • Prioritized background activity enables
Contact tracing isn't working on my device since I updated it to Android 12 (before the update I ran Android 11). I'm using: * Google Pixel 4 * latest Android 12 * CCTG 2.11.2 * Prioritized background activity enables

Could you please provide some more details? What exactly does not work? Does the app crash or does exposure logging not work?

Could you please provide some more details? What exactly does not work? Does the app crash or does exposure logging not work?
Poster

There is no exposure logged since the moment I updated. I already went to a supermarket so there should be something in the overview.

There is no exposure logged since the moment I updated. I already went to a supermarket so there should be something in the overview.

Did you

  1. Perform the steps mentioned in https://codeberg.org/corona-contact-tracing-germany/cwa-android#my-encounters-tab-shows-no-ids-even-though-exposure-logging-is-enabled-what-can-i-do
  2. Deactivate and reactivate exposure logging?

Sometimes this helps.

Did you 1. Perform the steps mentioned in https://codeberg.org/corona-contact-tracing-germany/cwa-android#my-encounters-tab-shows-no-ids-even-though-exposure-logging-is-enabled-what-can-i-do 2. Deactivate and reactivate exposure logging? Sometimes this helps.
Poster

Yes, I did both of them before opening this issue.

Yes, I did both of them before opening this issue.

@justCoding

Okay, good (or actually: Bad, since this makes it a bit more complicated 😅).

Could you click on "RISIKO-ERMITTLUNG AKTIV" on the "Start" tab and then click on "Erweiterte Einstellungen" and let us know if there is an ID shown as "Akteull verwendete ID"?

@justCoding Okay, good (or actually: Bad, since this makes it a bit more complicated 😅). Could you click on "RISIKO-ERMITTLUNG AKTIV" on the "Start" tab and then click on "Erweiterte Einstellungen" and let us know if there is an ID shown as "Akteull verwendete ID"?
Poster

Yes, there is an ID present.
As Android 12 did some "privacy" changes: is it possible that the app might require some extra permissions? I

Yes, there is an ID present. As Android 12 did some "privacy" changes: is it possible that the app might require some extra permissions? I
Poster

As the "Nearby devices" permission looks pretty promising, I will grant the permission and monitor the tracing page.

As the "Nearby devices" permission looks pretty promising, I will grant the permission and monitor the tracing page.
Poster

I think it works! Should've checked this earlier. When I disable the permission, I even get a warning, but it is disabled automatically - weird.

I think it works! Should've checked this earlier. When I disable the permission, I even get a warning, but it is disabled automatically - weird.
justCoding closed this issue 1 month ago
Owner

Let's keep this open for others to find and us to look for a workaround for this.

Let's keep this open for others to find and us to look for a workaround for this.
Bubu reopened this issue 1 month ago
Owner

Here's the related crash on my freshly updated android 12 device:

10-20 20:59:17.362 10666 10666 E AndroidRuntime: java.lang.RuntimeException: Unable to start service org.microg.gms.nearby.exposurenotification.ScannerService@e2f4616 with Intent { cmp=de.corona.tracing/org.microg.gms.nearby.exposurenotification.ScannerService }: java.lang.SecurityException: Need android.permission.BLUETOOTH_SCAN permission for android.content.AttributionSource@59b6df05: GattService registerScanner
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:4661)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.app.ActivityThread.access$2000(ActivityThread.java:247)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2095)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.os.Handler.dispatchMessage(Handler.java:106)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.os.Looper.loopOnce(Looper.java:201)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.os.Looper.loop(Looper.java:288)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.app.ActivityThread.main(ActivityThread.java:7842)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at java.lang.reflect.Method.invoke(Native Method)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:548)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1003)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: Caused by: java.lang.SecurityException: Need android.permission.BLUETOOTH_SCAN permission for android.content.AttributionSource@59b6df05: GattService registerScanner
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.os.Parcel.createExceptionOrNull(Parcel.java:2425)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.os.Parcel.createException(Parcel.java:2409)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.os.Parcel.readException(Parcel.java:2392)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.os.Parcel.readException(Parcel.java:2334)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.bluetooth.IBluetoothGatt$Stub$Proxy.registerScanner(IBluetoothGatt.java:1727)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.bluetooth.le.BluetoothLeScanner$BleScanCallbackWrapper.startRegistration(BluetoothLeScanner.java:426)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.bluetooth.le.BluetoothLeScanner.startScan(BluetoothLeScanner.java:278)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.bluetooth.le.BluetoothLeScanner.startScan(BluetoothLeScanner.java:154)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at org.microg.gms.nearby.exposurenotification.ScannerService.startScan(ScannerService.kt:124)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at org.microg.gms.nearby.exposurenotification.ScannerService.startScanIfNeeded(ScannerService.kt:99)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at org.microg.gms.nearby.exposurenotification.ScannerService.onStartCommand(ScannerService.kt:81)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:4643)
10-20 20:59:17.362 10666 10666 E AndroidRuntime: 	... 9 more
10-20 20:59:22.123 11485 11485 E AndroidRuntime: FATAL EXCEPTION: main
Here's the related crash on my freshly updated android 12 device: ``` 10-20 20:59:17.362 10666 10666 E AndroidRuntime: java.lang.RuntimeException: Unable to start service org.microg.gms.nearby.exposurenotification.ScannerService@e2f4616 with Intent { cmp=de.corona.tracing/org.microg.gms.nearby.exposurenotification.ScannerService }: java.lang.SecurityException: Need android.permission.BLUETOOTH_SCAN permission for android.content.AttributionSource@59b6df05: GattService registerScanner 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:4661) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.app.ActivityThread.access$2000(ActivityThread.java:247) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2095) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.os.Handler.dispatchMessage(Handler.java:106) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.os.Looper.loopOnce(Looper.java:201) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.os.Looper.loop(Looper.java:288) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.app.ActivityThread.main(ActivityThread.java:7842) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at java.lang.reflect.Method.invoke(Native Method) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:548) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1003) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: Caused by: java.lang.SecurityException: Need android.permission.BLUETOOTH_SCAN permission for android.content.AttributionSource@59b6df05: GattService registerScanner 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.os.Parcel.createExceptionOrNull(Parcel.java:2425) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.os.Parcel.createException(Parcel.java:2409) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.os.Parcel.readException(Parcel.java:2392) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.os.Parcel.readException(Parcel.java:2334) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.bluetooth.IBluetoothGatt$Stub$Proxy.registerScanner(IBluetoothGatt.java:1727) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.bluetooth.le.BluetoothLeScanner$BleScanCallbackWrapper.startRegistration(BluetoothLeScanner.java:426) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.bluetooth.le.BluetoothLeScanner.startScan(BluetoothLeScanner.java:278) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.bluetooth.le.BluetoothLeScanner.startScan(BluetoothLeScanner.java:154) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at org.microg.gms.nearby.exposurenotification.ScannerService.startScan(ScannerService.kt:124) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at org.microg.gms.nearby.exposurenotification.ScannerService.startScanIfNeeded(ScannerService.kt:99) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at org.microg.gms.nearby.exposurenotification.ScannerService.onStartCommand(ScannerService.kt:81) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:4643) 10-20 20:59:17.362 10666 10666 E AndroidRuntime: ... 9 more 10-20 20:59:22.123 11485 11485 E AndroidRuntime: FATAL EXCEPTION: main ```
Bubu added the
upstream-microg
label 1 month ago
Owner
microg tracking issue: https://github.com/microg/GmsCore/issues/1591

On my Pixel 4a it also has problems after updating to Android 12.

Sending the beacon seams to be working as expected. I also give the permission "Nearby devices". This permission is also activated by the CWA after fresh installation.

If I disable and re-enable the exposure logging it works for a while and than it stop working and I don't see new contacts of my 2nd device. Also if the CCTG is active.

On my Pixel 4a it also has problems after updating to Android 12. Sending the beacon seams to be working as expected. I also give the permission "Nearby devices". This permission is also activated by the CWA after fresh installation. If I disable and re-enable the exposure logging it works for a while and than it stop working and I don't see new contacts of my 2nd device. Also if the CCTG is active.

With the new GrapheneOS, which uses Android 12 and comes without microG, I also have some problems with CCTG. Besides not collecting any IDs, the Start page is just blank. I can navigate to other pages and they work, like Certificates or even the ID statistic page (which just shows no statistic unless the time it last worked). The same happens with the risk identification setting page. It is also just blank. Is this also because of the missing microG compatibility or a new bug?

With the new GrapheneOS, which uses Android 12 and comes without microG, I also have some problems with CCTG. Besides not collecting any IDs, the Start page is just blank. I can navigate to other pages and they work, like Certificates or even the ID statistic page (which just shows no statistic unless the time it last worked). The same happens with the risk identification setting page. It is also just blank. Is this also because of the missing microG compatibility or a new bug?
Owner

Missing microG shouldn't be a problem (the app then uses the bundled version). A blank page definitely sounds like a new/separate bug, maybe a rom specific one.

As this ticket is specifically about the contact tracing not working on A12, could you open a new issue and include some screenshots?

Missing microG shouldn't be a problem (the app then uses the bundled version). A blank page definitely sounds like a new/separate bug, maybe a rom specific one. As this ticket is specifically about the contact tracing not working on A12, could you open a new issue and include some screenshots?

I haven't done anything, but the blank pages now show up. Now only contact tracing doesn't work, so I will not open a new issue.

I haven't done anything, but the blank pages now show up. Now only contact tracing doesn't work, so I will not open a new issue.
Owner

Did you follow the instcution here in this issue for enabling contact tracing on A12?

https://codeberg.org/corona-contact-tracing-germany/cwa-android/issues/169#issuecomment-271642

Did you follow the instcution here in this issue for enabling contact tracing on A12? https://codeberg.org/corona-contact-tracing-germany/cwa-android/issues/169#issuecomment-271642

After granting the permission, disabling and enabling contact tracing it works again. Thanks!

After granting the permission, disabling and enabling contact tracing it works again. Thanks!

On my Pixel 4a it also has problems after updating to Android 12.

Sending the beacon seams to be working as expected. I also give the permission "Nearby devices". This permission is also activated by the CWA after fresh installation.

If I disable and re-enable the exposure logging it works for a while and than it stop working and I don't see new contacts of my 2nd device. Also if the CCTG is active.

I also did the Update to Android 12 on my Pixel 4a and allowed all permissions to the app. I can't activate exposure notification at all. The official Google way just provides the CWA from Play Store. See here https://support.google.com/android/answer/10775533

> On my Pixel 4a it also has problems after updating to Android 12. > > Sending the beacon seams to be working as expected. I also give the permission "Nearby devices". This permission is also activated by the CWA after fresh installation. > > If I disable and re-enable the exposure logging it works for a while and than it stop working and I don't see new contacts of my 2nd device. Also if the CCTG is active. I also did the Update to Android 12 on my Pixel 4a and allowed all permissions to the app. I can't activate exposure notification at all. The official Google way just provides the CWA from Play Store. See here https://support.google.com/android/answer/10775533
Owner

In progress MR at microg to fix this for both new installs and existing ones who upgraded/upgrade: https://github.com/microg/GmsCore/pull/1606

In progress MR at microg to fix this for both new installs and existing ones who upgraded/upgrade: https://github.com/microg/GmsCore/pull/1606

Hi, I have exactly the same problem. I'm using an

  • Xiaomi Mi Mix 2S with Android 12
  • CCTG 2.11.2.0 with the app integrated microG Version 18126580000

All Permissions are granted (incl. Nearby Devices) and battery optimisation is turned off. But since yesterday 0 IDs are collected, an actual used ID is shown in the "erweiterte Einstellungen". I already turned ID collecting on and off, restarted the device, deleted Cache and so on - nothing is changing. I also tried these steps without success.

Furthermore the Encounter check isn't updating since yesterday 2pm.

Maybe somebody could help me!

Hi, I have exactly the same problem. I'm using an * Xiaomi Mi Mix 2S with Android 12 * CCTG 2.11.2.0 with the app integrated microG Version 18126580000 All Permissions are granted (incl. Nearby Devices) and battery optimisation is turned off. But since yesterday 0 IDs are collected, an actual used ID is shown in the "erweiterte Einstellungen". I already turned ID collecting on and off, restarted the device, deleted Cache and so on - nothing is changing. I also tried [these steps](https://codeberg.org/corona-contact-tracing-germany/cwa-android#my-encounters-tab-shows-no-ids-even-though-exposure-logging-is-enabled-what-can-i-do) without success. Furthermore the Encounter check isn't updating since yesterday 2pm. Maybe somebody could help me!

After restarting the device for the fifth or sixth time it worked. Seems the same problem as here: https://codeberg.org/corona-contact-tracing-germany/cwa-android/issues/189

After restarting the device for the fifth or sixth time it worked. Seems the same problem as here: https://codeberg.org/corona-contact-tracing-germany/cwa-android/issues/189
Sign in to join this conversation.
No Milestone
No Assignees
7 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.