Could not check for risk assesement (related to same-device double checkin?) #121

Closed
opened 9 months ago by rugk · 1 comments
rugk commented 9 months ago

Avoid duplicates

  • Bug is not mentioned in the FAQ
  • Bug is specific for Android only, for general issues / questions that apply to iOS and Android please raise them in the documentation repository
  • Bug is not already reported in another issue

Technical details

  • Device name: Fairphone 3 (FP3)
  • Android version: 10 (Stock ROM)
  • App version: 2.0.3

Describe the bug

Yesterday (2021-04-22) at 22:15 (the message says), it could not
I retried 23:12 as I did the screenshot and it still did not work.

Later on, also CCTG (installed on the same device and also active, which should as per their FAQ not be a problem) shows the same warning.

Now as I create this issue, both apps got back to normal apparently, but I still wanted to report it.
Maybe you can make sure it’s not just a server issue (was it temporarily down yesterday? And if so, is there a public status page/monitoring)?

Steps to reproduce the issue

Yesterday go to the home screen.

I found this:
grafik

Risikoüberprüfung fehlgeschlagen
Der Abgleich der Zufalls-IDs mit dem Server ist fehlgeschlagen. Sie können den Abgleich manuell neu starten.

However, it could be related to the new checkin functionality, as I did try that just before:

  • I updated CWA. I played around with it (and maybe I already created the place, I don’t really remember the exact order). In any case, I also updated CCTG to v2.0.3.
  • I created a place (”another place”) with CWA.
  • I checked in to that place with CWA after some time. Expiration: 2h.
  • I checked in with the same device with CCTG some time later. Expiration: 2h.

I’m not sure when that issue happened, but it could well be after these 2h approximately.

My device has Google Play Services v21.12.13 (120408-367530751) and thus does use microg’s internal implementation of CCTG. As such according to the CCTG FAQ both apps use a different data set.

Expected behaviour

No error. Never… 😉

Possible Fix

In the future, maybe there should also be a button to report this problem to the devs (as you apparently do with crashes – I never had one, but I read about that) or at least show me the log/more debug information.

I never saw this issue before.


Originally reported to CWA upstream here: https://github.com/corona-warn-app/cwa-app-android/issues/2941

<!-- Thanks for reporting a bug 🙌 ❤️ Before opening a new issue, please make sure that we do not have any duplicates already open. You can ensure this by searching the issue list for this repository. If there is a duplicate, please close your issue and add a comment to the existing issue instead. Also, be sure to check our documentation first: https://github.com/corona-warn-app/cwa-documentation --> ## Avoid duplicates * [x] Bug is not mentioned in the [FAQ](https://www.coronawarn.app/en/faq/) * [x] Bug is specific for Android only, for general issues / questions that apply to iOS and Android please raise them in the [documentation repository](https://github.com/corona-warn-app/cwa-documentation) * [x] Bug is not already reported in another issue ## Technical details - Device name: Fairphone 3 (FP3) - Android version: 10 (Stock ROM) - App version: 2.0.3 ## Describe the bug <!-- Describe your issue, but please be descriptive! Thanks again 🙌 ❤️ --> Yesterday (2021-04-22) at 22:15 (the message says), it could not I retried 23:12 as I did the screenshot and it still did not work. Later on, also CCTG (installed on the same device and also active, which should [as per their FAQ](https://codeberg.org/corona-contact-tracing-germany/cwa-android/src/branch/main/FAQ_de.md#ich-habe-vorher-cwa-benutzt-m%C3%B6chte-jetzt-aber-zu-cctg-wechseln-was-muss-ich-tun) not be a problem) shows the same warning. Now as I create this issue, both apps got back to normal apparently, but I still wanted to report it. Maybe you can make sure it’s not just a server issue (was it temporarily down yesterday? And if so, is there a public status page/monitoring)? ## Steps to reproduce the issue <!-- include screenshots, logs, code or other info to help explain your problem --> Yesterday go to the home screen. I found this: ![grafik](https://user-images.githubusercontent.com/11966684/115926865-d0760a80-a483-11eb-93a2-6c8e008b7fd0.png) > **Risikoüberprüfung fehlgeschlagen** > Der Abgleich der Zufalls-IDs mit dem Server ist fehlgeschlagen. Sie können den Abgleich manuell neu starten. However, it could be related to the new checkin functionality, as I did try that just before: * I updated CWA. I played around with it (and maybe I already created the place, I don’t really remember the exact order). In any case, I also updated CCTG to v2.0.3. * I created a _place_ (”another place”) with CWA. * I checked in to that place with CWA after some time. Expiration: 2h. * I checked in with the same device with CCTG some time later. Expiration: 2h. I’m not sure when that issue happened, but it could well be after these 2h approximately. My device has Google Play Services v21.12.13 (120408-367530751) and thus does use microg’s internal implementation of CCTG. As such [according to the CCTG FAQ](https://codeberg.org/corona-contact-tracing-germany/cwa-android/src/branch/main/FAQ_de.md#ich-habe-vorher-cwa-benutzt-m%C3%B6chte-jetzt-aber-zu-cctg-wechseln-was-muss-ich-tun) both apps use a different data set. ## Expected behaviour No error. Never… :wink: <!-- A clear and concise description of what you expected to happen. --> ## Possible Fix In the future, maybe there should also be a button to report this problem to the devs (as you apparently do with crashes – I never had one, but I read about that) or at least show me the log/more debug information. <!--- Not obligatory, but suggest a fix or reason for the bug --> <!-- Add any other context about the problem here. --> I never saw this issue before. --- Originally reported to CWA upstream here: https://github.com/corona-warn-app/cwa-app-android/issues/2941
fynngodau added the
upstream-cwa
label 9 months ago
Owner

Since you also encountered this problem with CWA, it is not specific to CCTG. I have subscribed to the upstream CWA issue that you linked to be aware of any interesting developments.

Now as I create this issue, both apps got back to normal apparently, but I still wanted to report it.

Due to these reasons and due to the temporary nature of this issue, I think we can close this issue because I don't know any way to help fix it for the future.

Since you also encountered this problem with CWA, it is not specific to CCTG. I have subscribed to the upstream CWA issue that you linked to be aware of any interesting developments. > Now as I create this issue, both apps got back to normal apparently, but I still wanted to report it. Due to these reasons and due to the temporary nature of this issue, I think we can close this issue because I don't know any way to help fix it for the future.
fynngodau closed this issue 7 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.